FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

12006 questions

14286 answers

22527 comments

35869 members

+1 vote
30 views 1 comments
by
Hello,

I've configured the full control modem mode. I sent the commands ATE1, AT+CMGF=1 and AT&W, but after reset I see an internal process sending ATE0 and SMS mode is not text mode. Please, what commands should I add in System - > Start up script to enable echo (ATE1) and set SMS text mode (AT+CMGF=1) after device reset?

Thanks

Regards/Vicente
Firmware version: TRB1_R_00.07.02.7
by

I also see some internal process sending ATE0 and AT+CGMR to the Quectel modem after reset, even though I have disabled all services and mobile data in configuration. Also using the latest version TRB1_R_00.07.02.7

A tip: If you are having problems receiving URC:s for received SMS, calls or network registration like I did, check the command AT+qurccfg="urcport"

In my case, I just found out that the port was initally "usbat" and no URC:s were received. I changed it to "uart2" which seems to solve the problem.

1 Answer

0 votes
by
Hello,

When RS232 is set to modem full control configuration, gsmctl, command used to communicate with modem module does not work, thus modem can only be controlled over RS232 port meaning that startup scripts will not work.

Best regards,