FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

12006 questions

14286 answers

22527 comments

35870 members

0 votes
59 views 2 comments
by
Hi! I'm currently struggling with setting up a RUTX10 in a way, so it acts as a WLAN client and allows me to connect non-WLAN-capable devices to an existing network using the ethernet ports. Additional networks are not needed in this scenario. All devices should be in the same broadcast domain. I'm basically looking for a similar setup like we did with Unifi before: One AP acts as a repeater and the ethernet ports on the AP can be used to connect further devices.

This is what I did so far:

1. I deleted all the WAN interfaces since there's no WAN uplink needed (Network -> Interfaces)

2. I deleted all the WLAN interfaces since "Access Point" functionality is not needed (Network -> Wireless)

3. I enabled the "Multi AP" option, set the network name "MAIN" and made a zone "main" since the wizard asked for a new zone (Network -> Wireless -> Multi AP) Then I added the companies SSID and Key, enabled that profile and saved it. After some time the interface came up and was connected to the companies WLAN (yay!)

4. The new Interface appeared and got a DHCP lease from the companies WLAN (Network -> Interfaces) The webgui was not accessible from that address, so I set the firewall to "accept all" and deleted the new rule, the wizard just created in step 3. The webgui was now accessible from the companies network (yay!)

5. I chose the LAN interface and changed the physical port to eth1 (I assume this is the physically "WAN" labeled port) to use it as a management port with the default local IP address. It works, I'm connected to the webgui using that port and the default IP

6. I chose the MAIN interface, enabled "Bridge interface" and selected the physical Interface eth0

At this point the "MAIN" interface loses the IP address, so it's no longer accessible from the companies network. This would be okay, but clients connected to the ethernet ports can't connect to the company network either. I have no idea how to proceed there.

Thanks in advance!
by
Just to give you an idea why I need to do this and what my intentions are:

There's a large room in a factory and all clients are connected to access points mounted to the walls. There's one station in the center of the said room with some special devices next to it. I could connect said computer to the WLAN directly, but the other special devices only support ethernet connection. There's no (easy) option to get a wired connection there. So, I'm looking for a way to wirelessly extend the network.

2 Answers

+1 vote
by

Hello,

Could you check if the following configuration does not fit your requirements: https://wiki.teltonika-networks.com/view/RUTOS_relay_/_Wi-Fi_extender_/_repeater_/_bridge_configuration

Best regards,

Best answer
by
Thanks! This guide provided the right hint to solve the issue. Everything worked like a charm but for some reason I did not think of creating a seperate Interface for eth0, then bridging that with the wireless interface! I will quickly sum it up for further reference
0 votes
by

Thanks again to ZygimantasBliu for providing the right hints! Here's the step by step guide on how I managed to do what I described above

  1. Reset the router, set a password but skip the wizard
  2. Delete all WAN interfaces (Network -> Interfaces)
  3. Delete all Wireless profiles (Network -> Wireless)
  4. Still in Network -> Wireless, hit the "Add multi AP" button, then give it an appropriate name (e.g. the same as the SSID), add your companies SSID/Key pair, toggle everything to "on" and hit save & apply
  5. Go to Network -> Firewall and disable the firewall by changing everything to "Accept" in general settings
  6. Add a new Interface (Network -> Interfaces) called MGMT, enable "Bridge interfaces" and select eth1, set a default static IP address (e.g. 172.16.16.1) and enable the DHCP server (This turns the WAN port into a management port for easy local access. Thank me later whenever the wireless connection breaks)
  7. Edit the default LAN interface: In General Settings choose DHCP as the protocol, turn relay configuration on and select the Wireless Interface you created in step 4. Hit save & apply
  8. (Optionally: Enable STP in the "physical settings" for LAN if you inted to add switches to the 3 lan ports)

The LAN interface will have the status "stopped" but this doesn't matter. The bridge works! Your router should now be accessible using the IP address the wirelesss interface got from your companies WLAN. Clients connected to any LAN port will connect to the companies network.

In case there happens to be an issue with the wireless connection, plug your computer into the WAN port (which is MGMT now) to access the router.