FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
301 views 6 comments
by anonymous

Hello,
My RUTX09 uses both WAN and 4G connections.
I want my VoIP phones (10.0.0.240 and 10.0.0.241) register on the WAN (ADSL) connection and not the 4G connection (less reliable).

Here is my mwan3 file :

config globals 'globals'
        option mmx_mask '0x3F00'
        option rtmon_interval '5'
        option mode 'balance'

config interface 'mob1s1a1'
        option interval '3'
        option family 'ipv4'
        option enabled '1'

config interface 'mob1s2a1'
        option interval '3'
        option enabled '0'
        option family 'ipv4'

config interface 'wan'
        option interval '3'
        option family 'ipv4'
        option enabled '1'

config condition
        option interface 'wan'
        option track_method 'ping'
        list track_ip '1.1.1.1'
        list track_ip '8.8.8.8'
        option reliability '1'
        option count '1'
        option timeout '2'
        option down '3'
        option up '3'

config member 'wan_member_mwan'
        option interface 'wan'
        option metric '3'

config member 'wan_member_balance'
        option interface 'wan'
        option weight '2'

config policy 'mwan_default'
        list use_member 'mob1s1a1_member_mwan'
        list use_member 'mob1s2a1_member_mwan'
        list use_member 'wan_member_mwan'

config policy 'balance_default'
        list use_member 'mob1s1a1_member_balance'
        list use_member 'mob1s2a1_member_balance'
        list use_member 'wan_member_balance'

config rule 'ADSL'
        option sticky '0'
        option proto 'all'
        option use_policy 'balance_ADSL'
        list src_ip '10.0.0.240'
        list src_ip '10.0.0.241'
        list dest_ip '0.0.0.0/0'

config condition
        option interface 'mob1s1a1'
        option track_method 'ping'
        list track_ip '1.1.1.1'
        list track_ip '8.8.8.8'
        option reliability '1'
        option count '1'
        option timeout '2'
        option down '3'
        option up '3'

config member 'mob1s1a1_member_mwan'
        option interface 'mob1s1a1'
        option metric '1'

config member 'mob1s1a1_member_balance'
        option interface 'mob1s1a1'
        option weight '8'

config condition
        option interface 'mob1s2a1'
        option track_method 'ping'
        list track_ip '1.1.1.1'
        list track_ip '8.8.8.8'
        option reliability '1'
        option count '1'
        option timeout '2'
        option down '3'
        option up '3'

config member 'mob1s2a1_member_mwan'
        option interface 'mob1s2a1'
        option metric '2'

config member 'mob1s2a1_member_balance'
        option interface 'mob1s2a1'
        option weight '1'

config rule '4G'
        option proto 'all'
        list src_ip '10.0.0.1'
        list src_ip '10.0.0.62'
        option sticky '1'
        option timeout '600'
        option use_policy 'balance_4G'
        list dest_ip '0.0.0.0/0'

config policy 'balance_ADSL'
        list use_member 'wan_member_balance'

config rule 'default_rule'
        option dest_ip '0.0.0.0/0'
        option use_policy 'balance_default'
        option sticky '0'
        option proto 'all'

config policy 'balance_4G'
        list use_member 'mob1s1a1_member_balance'

Here, you can see no rules are active, and i don't understand why...

root@Teltonika-RUTX09:~# mwan3 rules
Active ipv4 user rules:

Active ipv6 user rules:

My troubleshoot file is attached

1 Answer

0 votes
by anonymous

Hello,

I have replicated your issue.

The rules seem to stop being displayed, when you add a second IP address in the rule. If you created separate rules for both source IPs, rules should be displayed.

Will forward it to the development team to look into.

As an alternative, could you create a backup of your current configuration and downgrade your device to RUTX_R_00.07.01.4 firmware and check if the same behavior occurs? 

Best regards,

by anonymous

Thank you for your answer.

With 7.01.4 firmware, rules are displayed, even if they are two :

root@Teltonika-RUTX09:~# mwan3 rules

Active ipv4 user rules:

  568  101K - balance_default  all  --  *      *       0.0.0.0/0            0.0.0.0/0

    0     0 - balance_ADSL  all  --  *      *       10.0.0.240           0.0.0.0/0

    0     0 - balance_ADSL  all  --  *      *       10.0.0.241           0.0.0.0/0

    0     0 - balance_4G  all  --  *      *       10.0.0.148           0.0.0.0/0

Active ipv6 user rules:

  124 19467 - balance_default  all      *      *       ::/0                 ::/0

However, even if the rules are visible, there are not applied...

Do I have to wait a bit for the rules to become active?

by anonymous

Additional information : there are errors when I restart mwan3 :

root@Teltonika-RUTX09:~# mwan3 restart

ip6tables v1.8.7 (legacy): host/network `10.0.0.240' not found

Try `ip6tables -h' or 'ip6tables --help' for more information.

ip6tables v1.8.7 (legacy): host/network `10.0.0.148' not found

Try `ip6tables -h' or 'ip6tables --help' for more information.

ip6tables v1.8.7 (legacy): host/network `10.0.0.240' not found

Try `ip6tables -h' or 'ip6tables --help' for more information.

ip6tables v1.8.7 (legacy): host/network `10.0.0.148' not found

Try `ip6tables -h' or 'ip6tables --help' for more information.

sh: out of range

sh: out of range

New troubleshoot file is attached.
by anonymous
Correction: after waiting a while, the rules are correctly applied.
So failover works on version RUTX_R_00.07.01.4.

Sorry for the wrong information.
by anonymous
A day later, the rules, although present, are no longer applied.

Very strange...
by anonymous

Hi ZygimantasBliu,

Do you have any news from the development team?

by anonymous
The issue is forwarded, but there is no update at the moment.