FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

12677 questions

15063 answers

24126 comments

47076 members

0 votes
80 views 2 comments
by
Hi,

I have a RUT950 on a remote location. About a year ago, the router stopped responding to SMS-messages after installing the RUT9_R_00.7.00 firmware. The problem has existed ever since also on later firmwares. The SMS-messages sent to the router also can not be found on the device by using the web ui nor by using the Gsmctl commands from the CLI. However, sending SMS-messages from the device works just fine. I have set no authorization for the get status -command and all numbers are allowed. I have also tried sending the message from another phone and number...

My current firmware is RUT9_R_00.07.02.7 and the internal modem firmware version is EC25ECGAR06A04M1G. While visiting the site, I have also factory resetted the router several times with no joy.

Do I have any other option left but to go back to the legacy FW?

Edit: added the troubleshoot-file. There seems to be some other problem also since it took just over 40 minutes until the router was back online. After that, I sent three SMS-messages (status, test, status) to the router and created the troubleshoot-file.
by

I see no received SMS in the logs. Could you try a different SIM, to check if the device receives SMS?

Did SMS reception stop immediately after installing RUT9_R_00.7.00 firmware or after some time using it?

Have you tried legacy firmware afterwards, or the last time the device was able to receive SMS  was a year ago? 

The troubleshoot file has numerous blocked IPs, which attempted to login to your router via SSH 22 port, from all over the world.

I would like you to try the following:

Flash firmware via bootloader menu to latest Legacy, which you can download here. This should completely clear your device. For instructions refer here. Check if you can receive SMS afterwards. Next, upload the Latest RutOS and also check, if SMS are received.

Next, before enabling HTTP(S) or SSH WAN, replace standard ports to random values above 1024 in Services -> Administration -> Access control and configure a strong and long (no less than 12 characters) password. If remote access is mandatory for a long period of time, consider using VPN or Teltonika's cloud platform RMS.

by
Yep, I have noticed the automated SSH brute-force attacks. That is one reason why I have not been too keen on going back to the legacy FW, and have not even tried whether it would fix the SMS problem. I changed the port numbers to random ones now, though.

Yes, the SMS-problem started right after installing the RUT9_R_00.7.00 -firmware. I will try flashing the router with the legacy FW and also if it would make any difference with another SIM-card. Not sure when though, since the router is installed on a top of a mast on a remote location.

Thank you for your efforts.

1 Answer

0 votes
by

Hello,

I would like you to attach a troubleshoot file from your RUT950 by editing your question. Please restart or power cycle the device, try sending a few SMS to the router, this should generate certain entries in the logs, then access router's WebUI, go to System -> Administration -> Troubleshoot section and download troubleshoot file from there. 

Best regards,