FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
420 views 4 comments
by anonymous
We have about 60 pcs. RUT950 in operation nationwide, all running latest FW RUT9_R_00.07.02.7. We have seen that the Reboot Scheduler is not working as expected. If first enabled, a reboot happens every night at 02:00 in addition to what you have put in. So if we put in  e.g. 04:00 every day, we get a reboot at 02:00 and then at 04:00.

When deleting the reboot shedule completely, it stills keep rebooting at 02:00 every night. It seems like the entry in the database is not deleted. Can this be fixed in next FW update please?

1 Answer

0 votes
by anonymous

Hello,

Does the issue happen to all 60 devices?

Did you perform firmware update with Keep settings option set to on?

Could you reset one of your devices to factory defaults (System -> Backup -> Restore default settings) and see if that helps?

Otherwise, it would be interesting to look at the troubleshoot file of one of the devices with the issue present. To generate the file, access router's WebUI, go to System -> Administration -> Troubleshoot section and download troubleshoot file from there. attach the file by editing your question. 

Best regards,

by anonymous

It does happen on all yes. FW have been uploaded from RMS and also from WebUI with Keep Settings enabled.
We have tried reset to Factory Default on several, but it's the same.
File uploaded.

by anonymous

There is a Crontab running in the background, which reboots your device daily at 02:00:

  • 0 02 * * sun,mon,tue,wed,thu,fri,sat /sbin/reboot -e

You can disable it by adding # in front of the crontab line via SSH, by editing /etc/crontab/root file with the following command:

  • vi /etc/crontabs/root

Press i to start editing. 

You can also modify existing crontab to reboot your device at your desired time. For more details on Crontab management with Teltonika devices refer here.

by anonymous

We have never used CLI or SSH for editing Crontabs on our routers. All configuration has always been done through WebUI. I guess this must be a bug in FW where /etc/crontabs/root gets an entry when Reboot Scheduler in WebUI is enabled. When disabling and/or deleting this feature in WebUI, Crontab is left unchanged.

by anonymous
I was not able to replicate the issue, thus it would be helpful if you could provide the exact steps on how does the issue occur to you. However, I did notice that, when there is an instance of periodic reboot configured, and the router is power cycled, duplicate crontabs are generated. I will forward the development team to look into this.