FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
564 views 17 comments
by anonymous
as  stated in the subject, several RUT950 devices with a connected camera, after some random time (even a few minutes)  disconnect from the mobile network and do not reconnect unless the device is rebooted
by anonymous
Hi,

I reconfigured the routers to disable the failover, but since I DID NOT enable this function this means that it is enabled by default, is it correct?
by anonymous
Hello,

The default configuration for our routers has this function disabled in the recent versions of RutOS (>v7);

In the earlier version, failover was enabled with wired WAN being the main source and mobile being the backup.

If you upgraded your devices from legacy OS, then the settings transferred through to the new version.

Let me know if you're still experiencing any issues!

Best regards,
DaumantasG
by anonymous
good afternoon D.,

unfortunately the 20 routers are still unstable regardless the changes you suggested (failover, manual APN,...)

now the routers are up, thanks to automatic scheduled reboot, and as you can imagine this situation is not tolerable from the customer point of view anymore

so I would suggest, if the information provided till now are not enough, to connect in remote assistance to my laptop and then to one of the routers and check personally if there is something wrong in our configuration

waiting for your response

best regards

gianpietro
by anonymous
Hello,

I've sent you a private message regarding remote session.

Best regards,
DaumantasG
by anonymous
good afternoon D.,

I have updated one modem and it seems more stable (but with no camera attached): is there a procedure to update the modem offline (i.e. uploading from the pc) ?

kind regards

gianpietro
by anonymous
good morning D.,

any update about an offline modem upgrade procedure?

best regards

gianpietro
by anonymous

Hello,

  

Unfortunately, it seems like the modem update to the newest version locally is not yet supported, and an online update would need to be done.

However, once it is ready, it should be as simple as downloading the image folder, saving it to the ext4 formatted flash drive, plugging it into the router, and running the command modem_updater -i [modem_ID] -p /tmp/sda1/[name of the folder]

We apologize for any inconvenience caused.

  

Best regards,
DaumantasG

1 Answer

0 votes
by anonymous

Hello,

I'm sorry to hear that you're having issues!

I have a few troubleshooting steps to offer:

  • I can see that some of your signal values are quite poor, perhaps the router is located where there might be a lot of RF noise? Please try repositioning it closer to the window. Mobile signal recommendations can be found here. If this does not help, try locking the router to lower frequency bands (B20/B8 for Europe);
  • As auto-APN is currently in use, I'd recommend setting the APN manually. This can be done by navigating to Network → Interfaces → MOB1S2A1 (for SIM2). APN value should be provided by your ISP;
  • Automatic modem reboot could be configured. This can be done by navigating to Services → Auto Reboot → Ping/Wget Reboot. There, a rule for modem reboot can be configured.
Let me know if this does not help.
Best regards,
DaumantasG
by anonymous
thanks for your response D.,

I uploaded a diagnostic file from one the most troubled routers, currently in lab for further tests, I don't know how much info from the past you could get from it

the Automatic reboot option has been configured (after the issues, not before) but I think that it's just a workaround and not a solution; we will try the manual APN and let you know if this helps

best regards

gianpietro
by anonymous
Thank you for the information!

I'll be awaiting your response about the manual APN. I'd also recommend trying a factory reset (if possible) to see if it solves the issue.

Best regards,

DaumantasG
by anonymous
One more question: investigating in system logs I can see several "WAN (mob1s1a1) is down, no more backups to switch"

what does that mean?

regards

gianpietro
by anonymous
Hello,

This means that SIM1 has lost connection, and as WAN failover is not set up, there isn't another WAN source to switch to. This may well be the issue that is causing the issues. This may happen because of poor signal, configuration issues, SIM card not being inserted properly, or even hardware faults.

Next time you see this message in the logs, please generate the troubleshoot file again, as it will help to identify the issue.

Best regards,
DaumantasG
by anonymous
hello,

unfortunately the manual APN has not helped, frequent disconnections are occurring in different routers
by anonymous
Hello,

Thank you for the information.

Perhaps the routers are located in the same building or general area? How many routers do you have deployed?

It depends on what information is shown in the logs before/after the disconnection to determine the root cause or at least get on the right track.

Best regards,

DaumantasG
by anonymous
the routers are 20, widespread located in a small city, all of them (some more often, some less) shows the same misbehaviour. From network events  I see only

WAN (mob1s1a1) is down, no more backups to switch

Mobile data  disconnected...

thaks for your support

regards

gp
by anonymous

If possible, please generate a Troubleshoot file after mobile data disconnection occurs and attach it to the original post.

Thank you.

by anonymous
attached to original post some troubleshoot file; just for clarification each router has one or two cameras connected that performs streaming video (we already tried to reduce the resolution)

does this model support this level of traffic? any known issue with italian provider named TIM?

best regards

gianpietro
by anonymous

Hello,

I think I might have found your issue.

In the logs, I can see that your router is testing if the connection is active, and as the failover rules are configured to only check with one ping to one Google DNS server, and if it loses it, it tries to switch to another WAN source.

If you only have one WAN source available, I'd recommend turning off failover. This can be done by navigating to Network → Failover and disabling all of the interfaces.

However, if failover is needed for you, I'd recommend increasing the number of pings sent before switching the interfaces. This can be done by navigating to Network → Failover and editing each interface to use more servers (Google DNS sometimes fails to ping, this is a known issue) and setting the Up and Down count to at least 3. Below attached are the default settings:

Note: Failover ping checks are completely separate from ping or wget reboot.

Hope this helps!

Best regards,
DaumantasG