subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
+1 vote
413 views 4 comments
by anonymous
after upgrading a RUT955 to RUT9_R_00.07.03 I have an issue changing the path to the file for MNEA collecting.
Entering a new path/file I get an error message, that only a-zA-Z0-9-_\. are allowed. No "/" anymore!
Exchanging "/" with "\" gives another message: Location must be prefixed with "/mnt/" to avoid...
There seems to be an inconsistency with the allowed characters.

Best regards,

by anonymous

Same here and this bug was in Firmware RUT9_R_00.07.02 too. The earlier Firmware worked for me.

I could not set the path to "/mnt/sda3/gps.txt". The latest firmware allowed me only "/mnt/sda3" if I try to write more I got a error message.

1 Answer

+1 vote
by anonymous

Thank you for bringing this up.

I will forward this issue to the development team to resolve with the future firmware releases.

Best regards,
Best answer
by anonymous

Setting file directory over several folders is not allowed from the WebUI in the 7.03 firmware version and only file in /mnt/ directory are accepted. Nested folders in file path will be supported in 7.04 firmware release. 

However, this validation limit comes only from the WebUI side. You can work around it by executing several commands over CLI/SSH:

  • uci set gps.nmea_collecting.location='/mnt/sda1/gps-data/20221218.nmea'
  • uci commit
  • reload_config

It should work afterwards.


by anonymous
The CLI commands helped. Thank you
by anonymous

Me the same. But I tried the commands, but the collection does not start. Is a enable command needed or something else?