FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
402 views 4 comments
by anonymous
Hi Team,

I have a brand new RUT950. Has all the latest software/firmware installed. Connected to 4G, and also connected to a wired WAN.

Using either WAN (mobile and wired), the wifi performance is terrible. MAX download is like 5mbps, MAX upload is about 6mbps.

I have followed the instructions on here 'update the modem' using SSH. It's made no difference. I feel like it's a wifi issue, more than a modem issue. I have tried laptops and mobiles on wifi, it's all no good :-(.

Any help please, this is pretty much useless like this.

Thank you!
by anonymous
Hi mate,

I have sent you a private message with attachments.

Many thanks.
by anonymous
Please also note, that connecting via ethernet direct to the RUT950 i get 25-35mbps download and about 7 upload, which is kind of almost acceptable.
by anonymous
I also connected 2 x wireless devices to the RUT950, and did a speedtest between the two devices direct using wifiman app (not to the internet), and the speeds were 60-70mbps, so the wifi itself seems quite capable, however the client device to the internet is absolutely horrible.

Thanks.
by anonymous

Could you try the following:

Login to the WebUI, navigate to Network -> Firewall. Enable the following option: Software flow offloading. See if that improves the WiFi situation.

What WiFi channel width is configured in Network -> Wireless section Global interface settings? Try switching between 20 and 40 MHz channel widths.

Also, can you confirm that you have a stable mobile connection, as the logs indicate continuous disconnects before generating troubleshoot file?

Could you try setting custom APN value according to your provider for mobile interface in Network -> Interfaces by editing mobile interface settings and disabling Auto APN option.

One more thing to check is to try different LTE frequency bands. You can modify bands in Network -> Mobile -> General. Try the following bands: B1, B7, B8, B28. 

1 Answer

0 votes
by anonymous

Hello,

I would like you to attach a troubleshoot file to your question. 

Please replicate your configuration with all of the WAN sources set up, then access router's WebUI, go to System -> Administration -> Troubleshoot section and download troubleshoot file from there. 

Some screenshots with speeds on separate WAN interfaces might be useful too.

Best regards,