FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
152 views 0 comments
by anonymous
Hello,

I want to configure the RUTXR1 in a manner that I have two VLANs, one in the address area 192.168.1.xxx and the other one in the area of 192.168.2.xxx . The first VLAN should work on the LAN port 1 and the other one on the LAN port 2 .  I know that I have to activate DHCP server for both "Interfaces", but somehow I don't get the second VLAN working on port 2.

Can anyone of you help me here?

1 Answer

0 votes
by anonymous

Hi,

So you are trying to configure port-based VLANs.

There is a wiki page describing the steps to configure VLANs (available HERE).

Have you:

  • Created a new interface in Network -> Interfaces -> add new instance for VLAN 2?
  • Configured VLANs in the Network -> VLANs -> Port-based? Port 2 should be set to untagged for the new VLAN and all other ports should be off for this VLAN. Other VLANs should have port 2 set to off.
  • Have you assigned the correct subnet to the interface? Network -> Interfaces -> edit VLAN interface. Set static as protocol and assign a subnet. (192.168.2.1, 255.255.255.0)
  • Assigned a physical interface to your VLAN interface? Network -> Interfaces -> edit VLAN. Go to 'physical settings' and assign a physical interface to a VLAN (eth0.2 or whichever you configured in Network -> VLAN -> port-based).
  • Is the DHCP enabled on the VLAN interface? Network -> Interfaces -> VLAN interface-> DHCP Server -> General setup -> Enable DHCP

     

  • Is the device, which you are trying to connect to RUTXR, configured to obtain an IP address automatically (using DHCP)?

Kind Regards,

Andzej