FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
557 views 10 comments
by anonymous
USB HDD not detected by RUT955 after upgrading from 00.07.02.7 to RUT9_R_00.07.03.

So far we tested this firmware on two of our RUT955 routers and they both have the same problem!
Furthermore we noticed the router interface is very sluggish compared to 00.07.02.7.

1. Disconnected USB HDD and tested with simple USB Stick > works fine
2. USB HDD Brand not working: Toshiba DTB440 4TB (PN: HDTB440MK3CA)
3. Factory reset via reset button and also via interface do not solve the problems
4. Firmware downgrade back to 00.07.02.7 > Above mentioned HDD works fine

1 Answer

0 votes
by anonymous

Hello,

The logs show that the device gets detected:

usb-storage 1-1.1:1.0: USB Mass Storage device detected
scsi host0: usb-storage 1-1.1:1.0
usb 1-1.3: new full-speed USB device number 4 using ehci-platform
scsi 0:0:0:0: Direct-Access     TOSHIBA  EXTERNAL_USB     5438 PQ: 0 ANSI: 6
sd 0:0:0:0: [sda] Very big device. Trying to use READ CAPACITY(16).
sd 0:0:0:0: [sda] 7814037164 512-byte logical blocks: (4.00 TB/3.64 TiB)
 sda: sda1 sda2 sda3
sd 0:0:0:0: [sda] Attached SCSI disk

Could you provide more details, how do you check for detected devices, what is your application?

I'd like you to attach a troubleshoot file from 7.2.7 firmware, where the drive gets attached properly.

It might also be that the HDD simply gets a different mount point.

Best regards,

by anonymous

Hello,

We did check under the following page of the router:

Services > USB Tools > General  >> with firmware 00.07.03. the page takes a long time to search for mounts.  After a while an error appears on the page  "Error loading data"  and no mounts are found. (normally there should be a sda3 and sda2 mount point/device because we split the HDD in 2 partitions)

RUT9_R_00.07.02.7 troubleshoot file 

The same error appears if we try it in other RUT955 and also on other Windows 10 OS desktop. 

I hereby attached a 00.07.02.7 troubleshoot file as requested

by anonymous

Thank you for the details.

The device does seem to be mounted as you have described with sda2 and sda3 mountpoints in 7.3:

[Filesystem usage statistics]

Filesystem                Size      Used Available Use% Mounted on
/dev/root                 9.8M      9.8M         0 100% /rom
tmpfs                    61.0M    180.0K     60.8M   0% /tmp
/dev/mtdblock6            3.8M    476.0K      3.3M  12% /overlay
overlayfs:/overlay        3.8M    476.0K      3.3M  12% /
tmpfs                   512.0K         0    512.0K   0% /dev
/dev/sda2                 1.9T    160.4M      1.9T   0% /mnt/sda2
/dev/mtdblock7          576.0K    344.0K    232.0K  60% /log
/dev/sda3                 1.7T    155.6M      1.7T   0% /mnt/sda3

The issue looks to be WebUI related. I have registered a ticket to the RnD. I will update, once there are news.

If it does not cause any inconveniences, I suggest to stay with 7.2.7 at the moment. 

by anonymous

Hello,

RnD is working on the solution at the moment. They might have found the reason, but would like additional information.

Could you login to the router via SSH with USB HDD connected, and post the output of the command below:

  • time fmt-usb-msd.sh unmountable

Best regards,

by anonymous
Hello,

In the meantime i took a RUT955 and upgraded the firmware to 00.07.03.1
 

root@Teltonika-RUT955:~# time fmt-usb-msd.sh unmountable

{

        "/dev/sda2": {

                "mountpoint": "/mnt/sda2",

                "dev": "/dev/sda2",

                "used": "2.7G",

                "available": "1.8T",

                "used_percentage": "0%",

                "fs": "ntfs",

                "label": "RACStorage"

        },

        "/dev/sda3": {

                "mountpoint": "/mnt/sda3",

                "dev": "/dev/sda3",

                "used": "157.8M",

                "available": "1.8T",

                "used_percentage": "0%",

                "fs": "ntfs",

                "label": "RACStorage2"

        }

}

real    5m 36.43s

user    0m 0.18s

sys     0m 30.97s
by anonymous

Hello,

Developers have provided a test firmware, which you can download from here.

It would be very helpful if you tested it and provided feedback, whether it solves your issue or requires further investigation.

Best regards,

by anonymous
Hello,

I performed the following steps:

1. Upgraded firmware to 00.07.03.86 with "keep settings option" checked

2. Logged into router. Noticed on Overview page it says MEMORY AND fLASH usage is 0%

3. Navigated to Services > USB Tools > Keeps loading for 10 second > then the same error appears: "Error while loading data"

4. Navigated to System > Administration > troubleshoot > keeps on loading for a while. Error appears:  "failed to load mounts"

5. Restore to Factory defaults

6. Navigated to USB tools > general >  same problem with storage...

7. Downgrade firmware to 07.02.07 (with HDD still connected > The process of downgrading is done. However the firmware is not
downgraded. it still had version 00.07.03.86 and the settings are not wiped. We noticed this before with firmwire 07.03 and 07.03.1

8. Disconnected HDD and downgraded firmware agin to 07.02.07. downgrade worked fine.
by anonymous
Thank you. Forwarded your feedback.
by anonymous

Hello,

Please check firmware from this link: https://kaunas.teltonika.lt:444/d/432c49f9f50f428f9369/

Another thing to keep in mind is that since 7.3 it is no longer possible to write to NTFS partitions, it is read only from there, thus you will probably need to reformat your hard drive to exFat, to be able to use it fully.

Best regards,

by anonymous

Hello,

I upgraded RUT955 router to RUT9_T_F10273_00.07.02.2165.
This time te HDD is detected fine in the web interface.

I understand from your message that firmware 7.3 and higher wil no longer support writing to NTFS paritions?
Any reason for this change? 

by anonymous
Thank you for your feedback.

The decision to move to exFAT was made due to memory constraints of the device with the aim to reduce FW size, because the NTFS-3G driver consumes quite a bit of flash, which otherwise could be used for additional packages and user files.

The official solution will be included in 7.4 firmware.

Best regards,