FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
761 views 6 comments
by anonymous

Hi into the Forum

I used the RUT240 before for many Projects. Setup of the Router inclusive DynDNS or openvpn used 20 min worktime.

Now with the firmware RUT2_R_00.07.02.4 it is horrible! I am troubleshoot for about over 6 hours !

dynDNS is running as Package, it seems that it works - but works not propper.
The IP we see in the field (yellow marked) is the IP which is stored at dyndns.org from the old Router.

As you can see:  "Last update": Never
Also "next Update" is empty

This looks for me, like the job is not working fine.
Cron-problem?  I don't know.

Has anyone the same Problems?

Thanks for answering




 

1 Answer

0 votes
by anonymous

Hello,

  

Thank you for reaching out!

There are a few issues that could cause this, and it depends on the DDNS provider, but:

  • Please update to a newer firmware, 7.2.7 or 7.3 can be used;
  • If this started happening after a firmware update, I'd recommend deleting the instance and recreating it;
  • Please make sure that hostname and domain fields contain the same URL (if not stated differently by the DDNS provider);
  • Password should be the same as your DDNS account password (if not stated otherwise);
  • Try toggling the HTTP secure toggle and see if that helps;
Configuration examples for a few providers can be found here.

 

I'd like you to navigate to System → Administration → Troubleshoot and generate a troubleshoot file. It can be attached to your original post. Attachments are only visible to Teltonika moderators.

  

Best regards,
DaumantasG 

by anonymous

Hello DaumantasG

Thanks for the fast reply!  I have done this:

- Update to  RUT2_R_00.07.03,  keep settings  --> same effect, dynDNS is not updating
- Update to  RUT2_R_00.07.03,  don't keep settings, setup new dynDNS instance  --> same effect, dynDNS is not updating
- toggle http:/https: --> same effect, dynDNS is not updating

enclosed the troubleshooting-file in the Original-Post

Best regards,
Markus

by anonymous

Hello,

From the troubleshoot file I can see a few issues:

  • Your mobile IP is in the private range
    • This means that it will not be accessible via the internet. Private IPs are defined by these ranges:
      • Class A: 10.0.0.0 to 10.255.255.255;
      • Class B: 172.16.0.0 to 172.31.255.255;
      • Class C: 192.168.0.0 to 192.168.255.255;
      • CGNAT: 100.64.0.0 to 100.127.255.255.  
    • Perhaps a different APN needs to be used to obtain a public IP address?
  • You have selected the wired WAN interface as the source for the IP address. To find a mobile IP, mob1s1a1 should be used as an IP address source. Currently, there are many errors in the logs due to the fact, that you have selected an interface that is not in use (wired WAN).

Let me know if resolving these issues helps!

Best regards,
DaumantasG

by anonymous

Hello DaumantasG

Thanks for remember me about private/public IPs.
I configure the Router here at my office for a customers location. There is a (old) router and a SIM with a public IP.

What I have done:
- I Changed form WAN to mob1s1a1: --> same effect, dynDNS is not updating
- toggle http:/https: --> same effect, dynDNS is not updating

After this, I opened a account on No-IP, maked the setup with a new instance..... and boooom: it worked on the router!

After this, I deleted the instance on dynDNS and opened a brand new instance (other name). It's unbelievable: tha instance on dynDNS works NOT  (checked http and https).

What the hell is wrong? Other RUT240 with old firmware work fine with dynDNS.

New screenshot online   hopto = no-ip

Thanks for helping
Markus

 

by anonymous

Glad it worked!

DynDNS sometimes requires an "Updater Client Key:" to be used instead of your account password. This can be configured by navigating to "Settings" → "Settings Overview" and there will be an option to generate the key at the bottom.

I believe HTTPS will also need to be used in this setup.

Best regards,
DaumantasG

by anonymous

Hello DaumantasG

Thanks for the idea with the option, to generate a "key". I found the section in the account, but I was not sure, if "to generate a key" stops the access from other productive routers they used "only password".

Because of this, I created a new account on dynDNS to test this.I opened also a new Instance, does the same on the dynDNS-Section in the Router and then: WORKED immediately (without key).

WOW - what does it mean to me?


This means, that a new created Account has another behavior than a old account!

I will contact dynDNS to clear this problem. This is an absolutely NoGo !

Thanks for helping me to find out this.

Best regards,
Markus

by anonymous
Glad I could help!

  

Best regards,
DaumantasG