FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
506 views 2 comments
by anonymous

I have a some problems with my device RUT955. 

1.- The device doesn´t have communication with the serial terminal in full control (Modem Mode). I send the AT command, but the device doesn´t read the AT commands. 

2. The device doesn´t recognize the SIM. 

I used RUT9_R_00.07.03_WEBUI.bin firmware version.

1 Answer

0 votes
by anonymous

Hello,

  

Thank you for reaching out!

Mobile will be shown as not detected, because the serial device is in full control of the modem, and your RUT955 cannot see anything that is happening. It depends on what the modem control is needed for, but for simpler things like sending SMS I'd recommend using "Partial Control". I'd like you to try a few troubleshooting steps:

  • If the update was done from legacy RutOS versions (≤v6) (as seen in the screenshot), and the option "Keep settings" was selected, I'd recommend performing a factory reset;
  • Try disabling the modem control and see if the device can get an internet connection/register on the network;
Let me know how these steps went, and if the issue persists, please disable the Modem Control, navigate to System → Administration → Troubleshoot and generate a troubleshoot file. It can be attached to the original post and will only be visible to Teltonika moderators.

  

Best regards,
DaumantasG 

by anonymous
The idea is to receive SMS to send it to an MCU by RS232, but in Partial Control the SMS isn´t displayed automatically in the serial terminal and i need it.

My problem is that the firmware doesn´t show the mobile settings and i don´t communicate with the RS232

I uploaded the troubleshoot file.
by anonymous

Hello,

  

Thank you for the information!

I'm still not sure if I understand the issue. If you believe this is an issue with the device (rather than software issues), I'd ask you to disable the modem control via RS232 and generate a troubleshoot file then (as in the current troubleshoot file it is hard to determine which errors are real, and which are generated, because the device is not in control of the modem).

Also, how are you determining that the device cannot recognize the SIM card? All of the mobile troubleshooting needs to be done with modem control disabled.

  

Awaiting your response!

Best regards,
DaumantasG