FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
1,162 views 1 comments
by anonymous
Hi,

on a RUTX09 FW 7.02.6 we are having the following issue at least three times in the last four weeks:

Communication lost to all internal network devices connected to LAN (eth0) and LAN45 (eth0.45) while LTE-router is still accessible via mobile connection and OpenVPN.

(LAN45  (eth0.45) is created via VLAN 45)

This happened at least three times during the last 4 weeks and could be resolved by rebooting the router via the GUI.

Logfiles are showing these entries:

.....

Tue Jan  3 10:51:21 2023 kern.alert kernel: [110698.830448] 8<--- cut here ---

Tue Jan  3 10:51:21 2023 kern.alert kernel: [110698.830486] Unhandled fault: imprecise external abort (0x1c06) at 0xb6f1c02b

Tue Jan  3 10:51:21 2023 kern.alert kernel: [110698.832409] pgd = 603d3ba2

Tue Jan  3 10:51:21 2023 kern.alert kernel: [110698.839688] [b6f1c02b] *pgd=8bd1c835, *pte=8b05675f, *ppte=8b056c7f

Tue Jan  3 10:51:21 2023 kern.alert kernel: [110698.945715] 8<--- cut here ---

Tue Jan  3 10:51:21 2023 kern.alert kernel: [110698.945755] Unhandled fault: imprecise external abort (0x1c06) at 0xb6f1c02b

Tue Jan  3 10:51:21 2023 kern.alert kernel: [110698.947679] pgd = a00beefb

Tue Jan  3 10:51:21 2023 kern.alert kernel: [110698.954958] [b6f1c02b] *pgd=8edd5835, *pte=00000000, *ppte=00000000

Tue Jan  3 10:51:26 2023 user.notice : Added device handler type: bonding

Tue Jan  3 10:51:26 2023 user.notice : Added device handler type: 8021ad

Tue Jan  3 10:51:26 2023 user.notice : Added device handler type: 8021q

Tue Jan  3 10:51:26 2023 user.notice : Added device handler type: macvlan

Tue Jan  3 10:51:26 2023 user.notice : Added device handler type: veth

Tue Jan  3 10:51:26 2023 user.notice : Added device handler type: bridge

Tue Jan  3 10:51:26 2023 user.notice : Added device handler type: Network device

Tue Jan  3 10:51:26 2023 user.notice : Added device handler type: tunnel

Tue Jan  3 10:51:28 2023 kern.info kernel: [110706.252242] br-lan: port 1(eth0) entered disabled state

Tue Jan  3 10:51:28 2023 kern.info kernel: [110706.257079] br-lan: port 1(eth0) entered disabled state

Tue Jan  3 10:51:29 2023 kern.info kernel: [110706.458864] br-LAN45: port 1(eth0.45) entered disabled state

Tue Jan  3 10:51:29 2023 kern.info kernel: [110706.462148] device eth0.45 left promiscuous mode

Tue Jan  3 10:51:29 2023 kern.info kernel: [110706.463595] device eth0 left promiscuous mode

Tue Jan  3 10:51:29 2023 kern.info kernel: [110706.468442] br-LAN45: port 1(eth0.45) entered disabled state

Tue Jan  3 10:51:29 2023 daemon.warn dnsmasq[28257]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry

Tue Jan  3 10:51:29 2023 kern.info kernel: [110706.682405] br-LAN45: port 1(eth0.45) entered blocking state

Tue Jan  3 10:51:29 2023 kern.info kernel: [110706.682442] br-LAN45: port 1(eth0.45) entered disabled state

Tue Jan  3 10:51:29 2023 kern.info kernel: [110706.687524] device eth0.45 entered promiscuous mode

Tue Jan  3 10:51:29 2023 kern.info kernel: [110706.692948] device eth0 entered promiscuous mode

....

[100753.008628] Unhandled fault: external abort on non-linefetch (0x1008) at 0xb6f6996c

[100753.010561] pgd = 08a2ecf7

[100753.018524] [b6f6996c] *pgd=8f1c3835, *pte=86ff659f, *ppte=86ff6e7e

[110698.830448] 8<--- cut here ---

[110698.830486] Unhandled fault: imprecise external abort (0x1c06) at 0xb6f1c02b

[110698.832409] pgd = 603d3ba2

[110698.839688] [b6f1c02b] *pgd=8bd1c835, *pte=8b05675f, *ppte=8b056c7f

[110698.945715] 8<--- cut here ---

[110698.945755] Unhandled fault: imprecise external abort (0x1c06) at 0xb6f1c02b

[110698.947679] pgd = a00beefb

[110698.954958] [b6f1c02b] *pgd=8edd5835, *pte=00000000, *ppte=00000000

[110706.252242] br-lan: port 1(eth0) entered disabled state

[110706.257079] br-lan: port 1(eth0) entered disabled state

[110706.458864] br-LAN45: port 1(eth0.45) entered disabled state

[110706.462148] device eth0.45 left promiscuous mode

[110706.463595] device eth0 left promiscuous mode

[110706.468442] br-LAN45: port 1(eth0.45) entered disabled state

[110706.682405] br-LAN45: port 1(eth0.45) entered blocking state

[110706.682442] br-LAN45: port 1(eth0.45) entered disabled state

[110706.687524] device eth0.45 entered promiscuous mode

[110706.692948] device eth0 entered promiscuous mode

[110706.702196] br-LAN45: port 1(eth0.45) entered blocking state

[110706.702504] br-LAN45: port 1(eth0.45) entered forwarding state

[110706.717111] br-lan: port 1(eth0) entered blocking state

[110706.717172] br-lan: port 1(eth0) entered disabled state

[110706.725389] br-lan: port 1(eth0) entered blocking state

[110706.726815] br-lan: port 1(eth0) entered forwarding state

[121246.946866] 8<--- cut here ---

[121246.946905] Unhandled fault: imprecise external abort (0x1c06) at 0xb6ec202b

[121246.948829] pgd = e10c8e25

[121246.956109] [b6ec202b] *pgd=8db4f835, *pte=8badc75f, *ppte=8badcc7f

[121246.959115] 8<--- cut here ---

[121246.965312] Unhandled fault: imprecise external abort (0x1c06) at 0xb6ec202b

[121246.968182] pgd = d8512f35

[121246.975465] [b6ec202b] *pgd=8d828835, *pte=8d3677df, *ppte=8d367e7f

Could someone please have a look at this issue.

Thanks

Wolfgang

1 Answer

0 votes
by anonymous

Hi,

Could you please share a bit more details:

  • Was the router working fine before and suddenly started to have these issues?
  • Has anything changed in the configuration of the device?
  • For how long does the device work fine after the reboot? Any patterns or does it happen randomly?
  • What devices are connected to the RUTX09?
  • Do you have other RUT devices? If you do, are they working fine?
  • Have you tried to restore the device to factory default or reinstall the firmware via bootloader?

Thanks.

Kind Regards,

Andzej

by anonymous

Hi Andzej,
thanks for your reply and your questions.

  • Was the router working fine before and suddenly started to have these issues?
    Yes
  • Has anything changed in the configuration of the device?
    - Update to the FW 7.02.6 (August 2022)
    - Configuration of 
    port 1(eth0.45) with VLAN ID 45 (August 2022)
     
  • For how long does the device work fine after the reboot? Any patterns or does it happen randomly?
    - the device till now worked for 4 month, 10 days, 8 days after reboot. No patterns, problem seems to happen randomly.

     
  • What devices are connected to the RUTX09?
    There are two devices connected. The device LAN1 is an Media converter from 100TX to 100FX which is connected for several month.
    On LAN 3 (Port Based VLAN ID 45) is a second device. I have to figure out which device.

     
  • Do you have other RUT devices? If you do, are they working fine?
    We have around 70 RUTX-devices out in the field. Most of them are placed at windfarms and working (nearly) fine. Some (about 3) have unresolved issues.
    We are planning for around 100 additional devices in the next two years.

     
  • Have you tried to restore the device to factory default or reinstall the firmware via bootloader?
    The actual running FW 7.02.6 has been installed in August 2022 via bootloader after a factory reset.
    After the issue  occured the first time (Dec. 16th.) nothing was changed. We are thinking of replacing the router, but it is about two hours driving to the site (windfarm) but first of all we wan't to narrow down the issue.

    Kind Regards,
    Wolfgang Regel
    Regel IT Consulting