FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
1,554 views 4 comments
by anonymous

Hello,

I'm mounting a network share using the USB Tools on my RUTX50 FW RUTX_R_00.07.03

The default version in the template is set with

max protocol = SMB1

But if I try to change it to SMB2 or SMB3 and use vers=2.0 and vers=3.0 in my /etc/fstab file, it does not work and I get

mount error: Server abruptly closed the connection.

This can happen if the server does not support the SMB version you are trying to use.

The default SMB version recently changed from SMB1 to SMB2.1 and above. Try mounting with vers=1.0.

mount error(112): Host is down

Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) and kernel log messages (dmesg)

It would be good if in the next firmware updates you update this setting to the latest samba version, because 1.0 is quite old and vulnerable.

1 Answer

0 votes
by anonymous

Hello,

Thank you for reaching out!

On RUTX_R_00.07.03.1, the default SMB version seems to be 2, could you clarify which firmware version you're currently on? If it's not v7.3.1, could you try upgrading?

If this does not help, could you try a factory reset?

Best regards,
DaumantasG

by anonymous

I've updated the firmware. Deleted the samba configuration, and created it again. I've set
 
max protocol = SMB2

and it works to mount the drive using vers=2.0

But I tried the same steps with

max protocol = SMB3

and even after restarting the samba service from the CLI, does not work to mount it from my pc using vers=3.0, or even vers=2.0
Setting max protocol to SMB3 seems to cause problems

by anonymous
Hello,

  

Samba3.6 should be the latest supported version. Samba4 should also be added in the future.

If Samba3.6 does not work, let me know.

Best regards,
DaumantasG
by anonymous

Steps I did:

  1. Remove the shared directory
  2. Change the template line max protocol to SM3
  3. Enter the router CLI and executing `service samba restart`
  4. Add the shared directory again in USB Tools
  5. Try to mount from my computer, having the option vers=3.0 in /etc/fstab/
And it does not work, I get the error mentioned in my first message
by anonymous

Hello,

  

Sorry for the misunderstanding.

SMB1 includes Samba v1, while SMB2 includes Samba v2 and Samba v3. I understand why this can be confusing, but unless your client shows that it is using Samba v2, rather than Samba v3, it should all be working.

  

Best regards,
DaumantasG