FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14110 questions

16770 answers

27532 comments

53890 members

0 votes
101 views 2 comments
by
Updated to 00.07.03.1 on my RUTX10 and my samba share now stopped working. I can browse the share but it only shows two .ds-files, not the actual content of the drive.

If I connect the shared USB-HDD directly to my PC all files show up correctly. Everything worked before I updated. Don't remember the last firmware version but the last time I updated it was in September or October.

Have restarted the router and disconnected/reconnected the drive.

2 Answers

0 votes
by
Since 7.3 for the data to be written to an external HDD, it has to be formatted to exFAT filesystem.
Best answer
0 votes
by

Hello,

Does the USB - HDD appear in Services > USB Tools > General page?

Have you tried to reset the device to factory defaults and reconfigure it?

Could you generate a troubleshoot file from the deice? Make sure the issue replicates, then access router's WebUI, go to System -> Administration -> Troubleshoot section and download troubleshoot file from there.

You can also check if 7.2.7 firmware version results with the same behavior.

Best regards,

by

Hi,

No, it does not appear in USB Tools - General page.

I'm not very keen on reseting the device to factory defaults as I've made quite extensive configuration for firewall rules etc, but like i said it worked on the previous firmware that i used. Last updated in September or October (don't remember the exact version, but it was the latest then, not the mass production build).

Downgrading to 7.2.7 also states that my configuration will be lost, so I've not done that.

I restarted my usb HDD and reconnected it to my RUTX10, then waited a couple of minutes and generated a troubleshoot file. How can I send It securely to you? I don't want to publish my logs here where everyone might access it.

And like I said, I don't think the problem is with the USB HDD itself. I've connected it to two different PCs directly and all files show up ok.

EDIT:

Saw this in the logs. Never had a problem with 2TB limit on older firmware versions:

Mon Jan  9 14:28:54 2023 kern.info kernel: [68458.458208]  sda: sda1

Mon Jan  9 14:28:54 2023 kern.notice kernel: [68458.460991] sd 0:0:0:0: [sda] Attached SCSI disk

Mon Jan  9 14:28:57 2023 kern.err kernel: [68461.551439] ntfs: (device sda1): parse_ntfs_boot_sector(): Volume size (2TiB) is too large for this architecture.  Maximum supported is 2TiB.  Sorry.

Mon Jan  9 14:28:57 2023 kern.err kernel: [68461.551489] ntfs: (device sda1): ntfs_fill_super(): Unsupported NTFS filesystem.

Mon Jan  9 14:28:57 2023 daemon.err block: mounting /dev/sda1 (ntfs) as /mnt/sda1 failed (22) - Not a tty

Mon Jan  9 14:29:49 2023 kern.info kernel: fstab configuration has been changed

Mon Jan  9 14:30:03 2023 daemon.err uhttpd[2132]: Command failed: Not found

by
Hi again,

I did as you said and formatted the drive to extFAT and now it can be shared by the RUTX10 again.

Thanks for all your help, appreciate it.