FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
289 views 2 comments
by anonymous
Hello, starting point was a router RUT240 with latest legacy firmware 1.14.6.
Router was online and connected to APN. APN setting was Auto-APN.

Then, remote firmware update to 07.03.1 including "keep all settings". After the firmware update the router was offline.

Onsite visit showed that the setting "Auto-APN" was lost. Instead, the APN setting was "custom" with empty APN name.
All other settings seem to be still the same.

Can someone confirm this behavior?
by anonymous

I tried to upgrade a second device from firmware 1.14.6 to 07.03.4.
This version 07.03.4 according to the changelog had a bugfix for "keep all settings". So I gave it a try. However, after remote firmware update, the RUT240 did not connect to the mobile network (same behavior as in the original post). I went onsite and found that "OPERATOR SETTING" was enabled as shown in the screenshot.

After I disabled this option, then the device without hesitation connected to the mobile network. 

According to the router's manual, the default setting should be "off". So I really wonder why this is enabled after firmware update and thus, preventing the device from connecting to the mobile phone network. I also attach a screenshot from the "OPERATOR LISTS". To me this seems to be a problem with the initial configuration after firmware update.

1 Answer

0 votes
by anonymous

Hello,

The issue might have occurred due to "update to 07.03.1 including "keep all settings"." , as there is a quite big difference between firmware versions.

I have not replicated your described behavior locally, Auto APN remained set after update with Keep settings. The issue might stem from the modem module within the device or operator specifics. 

Do you have other devices, showing the same behavior?

Does the connectivity establish, when Auto APN is set again in 7.3.1?

Best regards,

by anonymous
Hello, I have not tried with other devices yet. First wanted to clarify why the very first one did not work.
Operator is Vodafone, by the way.
And yes, when I set Auto-APN on 7.3.1, then the connectivity was established again.

I will observe this topic when updating other stations.