subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
712 views 5 comments
by anonymous

Hi Teltonika team,

I would like to connect a NMEA 0183 device (it uses 2-wire RS422) to a RUT955 as a client transmitting data to a UDP server. The device just transmits NMEA sentences (one way communication). 

Until now I have tried to connect NMEA Out + of the device to Pin 5 (RUT955 RS485 connector) and NMEA Out - to PIN 2 respectively.

From CLI I entered cat /dev/rs485 but no data appear. I have verified that the device produces output by connecting elsewhere.

Do you have any instructions on how to properly establish the connection?

Attached two files with the configuration of serial Over IP service.

1 Answer

0 votes
by anonymous


The first thing to check is the connector itself. Do you have pins shorted as in the picture below:

Next would be to check if the RS485 configuration settings match between RUT955 and your NMEA device.

For testing I have used USB to RS485 cable with the following client configuration and PuTTy as my serial device:

For server, I used a remote PC with Hercules running and data was received:


Best regards,

by anonymous

Thanks for your reply. I am not able for a detailed answer I get the error message "Maximum length is 12000 characters"

My device has RS422 output not RS485. Tried to short the pins as you suggested also.  Not any success so far.

The device works with other equipment at 38400,8,N,1

Are you sure that it is OK with RS422?

by anonymous

My bad. All of the above is in referenced to RS485.

Could you please check suggestion here, regarding connector details and also enable Full Duplex in the WebUI configuration? RS485  full duplex system should be equivalent to RS422, though, as for 2 wire mode, I am not quite sure. If the suggested wiring of the connector does not work, functionality is likely not feasible. At least least the RS485 chip's datasheet suggests that it is full duplex only. 

by anonymous

The suggestion  you mentioned refers to 5-wire RS422 not 2-wire which is my case. Also, 2-wire RS422 is by definition half-duplex (in my case the device sends data out blindly)

by anonymous

I have just noticed here that firmware version RUT9_R_00.07.03.2 fixed a relevant problem

Did not have the chance to try the connection with the new firmware yet

by anonymous

Sum up: Trying to connect RS422 device through RS485 in Over IP mode. 

I can verify that the connection to the port and the device works. I can see incoming data in Console mode. When disabling Console and enabling the Over IP mode with the same settings (baud rate etc) no data appear.

Tested with firmware  RUT9_R_00.07.03.2