FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
519 views 17 comments
by anonymous
Dear Teltonika-Team,

I checked all 07.xx.xx versions, and since 00.07.03 the command "ubus call sim change" is switching to sim2 but no "connect" possible anymore. I freshly installed different firmwares and until 00.07.02.7 this command/switch is working well, so that sim2 gets "connected" state.

This is pretty simple to reproduce, please test.

Thx for help,
Rainer

1 Answer

0 votes
by anonymous

Hello,

  

I've tested it, and 10-15 seconds after running the command I was able to use the SIM2 for mobile data just fine on RUT955.

I'd like you to reproduce the issue with the newest available firmware, run the command and after 5 minutes navigate to System → Administration → Troubleshoot and generate a troubleshoot file. It can be attached to the original post and will only be visible to Teltonika moderators.

Awaiting your response!

  

Best regards,
DaumantasG

by anonymous

I did as you mentioned (all fresh, no old settings).

Same issue!

Tests:
a) Reboot to the default sim1: Sim1 is working well. But an "ubus call sim change" should change to sim2 but it never connects to any Provider/APN.
b) Reboot to the default sim2: Sim2 is working well. But an "ubus call sim change" should change to sim1 but it never connects to any Provider/APN.

What could we do now? Modem-Update?

(btw: after a "gsmctl --reboot" I got the WebUI message "Failed to load mobil data")

Thx for any help,
BR Rainer

# Typical messages according to issue above are:
...

Mon Jan 30 14:00:36 2023 daemon.info mobifd: [gsm.modem0] APN 'web.vodafone.de' isn't prepared for PDP 1, preparing it
Mon Jan 30 14:00:37 2023 daemon.info mobifd: [gsm.modem0] APN 'web.vodafone.de' was successfully prepared for PDP 1
Mon Jan 30 14:00:37 2023 daemon.info mobifd: [gsm.modem0] Attempting to establish connection to operator with 5 seconds of timeout
Mon Jan 30 14:00:47 2023 daemon.info mobifd: [gsm.modem0] APN '' isn't prepared for PDP 1, preparing it
Mon Jan 30 14:00:47 2023 daemon.info mobifd: [gsm.modem0] APN '' was successfully prepared for PDP 1
Mon Jan 30 14:00:47 2023 daemon.info mobifd: [gsm.modem0] Attempting to establish connection to operator with 5 seconds of timeout
Mon Jan 30 14:00:57 2023 daemon.info mobifd: [gsm.modem0] APN 'home.vodafone.de' isn't prepared for PDP 1, preparing it
Mon Jan 30 14:00:57 2023 daemon.info mobifd: [gsm.modem0] APN 'home.vodafone.de' was successfully prepared for PDP 1
Mon Jan 30 14:00:57 2023 daemon.info mobifd: [gsm.modem0] Attempting to establish connection to operator with 5 seconds of timeout
Mon Jan 30 14:01:07 2023 daemon.info mobifd: [gsm.modem0] APN 'web.vodafone.de' isn't prepared for PDP 1, preparing it
Mon Jan 30 14:01:08 2023 daemon.info mobifd: [gsm.modem0] APN 'web.vodafone.de' was successfully prepared for PDP 1
Mon Jan 30 14:01:08 2023 daemon.info mobifd: [gsm.modem0] Attempting to establish connection to operator with 10 seconds of timeout
Mon Jan 30 14:01:28 2023 daemon.info mobifd: [gsm.modem0] APN '' isn't prepared for PDP 1, preparing it
Mon Jan 30 14:01:28 2023 daemon.info mobifd: [gsm.modem0] APN '' was successfully prepared for PDP 1
Mon Jan 30 14:01:28 2023 daemon.info mobifd: [gsm.modem0] Attempting to establish connection to operator with 10 seconds of timeout
Mon Jan 30 14:01:48 2023 daemon.info mobifd: [gsm.modem0] APN 'home.vodafone.de' isn't prepared for PDP 1, preparing it
Mon Jan 30 14:01:48 2023 daemon.info mobifd: [gsm.modem0] APN 'home.vodafone.de' was successfully prepared for PDP 1
...

by anonymous
I've sent you a private message.

Best regards,
DaumantasG
by anonymous

Thx for detailed info about modem-update - it worked with exit code 0.

Afterwards I was able to switch a few times between sim1 and sim2.
But suddenly a switch hangs endless and either logread -f does not show anything anymore or I see endless repearting below messages (but WebUI seems still working):

...
Tue Jan 31 21:13:46 2023 daemon.err mobifd: [gsm.modem0] Failed to get information about all PDP contexts

Tue Jan 31 21:13:46 2023 daemon.info mobifd: [gsm.modem0] APN '' isn't prepared for PDP 1, preparing it
Tue Jan 31 21:13:46 2023 daemon.err mobifd: [gsm.modem0] Failed to set PDP 1 context
Tue Jan 31 21:13:46 2023 daemon.err mobifd: [gsm.modem0] Failed to insert '' APN
Tue Jan 31 21:13:46 2023 daemon.info mobifd: Failed to prepare connection for "gsm.modem0". Waiting 0 seconds
Tue Jan 31 21:13:46 2023 daemon.err mobifd: [gsm.modem0] Failed to get information about all PDP contexts
Tue Jan 31 21:13:46 2023 daemon.info mobifd: [gsm.modem0] APN '' isn't prepared for PDP 1, preparing it
Tue Jan 31 21:13:46 2023 daemon.err mobifd: [gsm.modem0] Failed to set PDP 1 context
Tue Jan 31 21:13:46 2023 daemon.err mobifd: [gsm.modem0] Failed to insert '' APN
Tue Jan 31 21:13:46 2023 daemon.info mobifd: Failed to prepare connection for "gsm.modem0". Waiting 0 seconds
Tue Jan 31 21:13:46 2023 daemon.err mobifd: [gsm.modem0] Failed to get information about all PDP contexts
Tue Jan 31 21:13:46 2023 daemon.info mobifd: [gsm.modem0] APN '' isn't prepared for PDP 1, preparing it
Tue Jan 31 21:13:46 2023 daemon.err mobifd: [gsm.modem0] Failed to set PDP 1 context
Tue Jan 31 21:13:46 2023 daemon.err mobifd: [gsm.modem0] Failed to insert '' APN
Tue Jan 31 21:13:46 2023 daemon.info mobifd: Failed to prepare connection for "gsm.modem0". Waiting 0 seconds
Tue Jan 31 21:13:46 2023 daemon.err mobifd: [gsm.modem0] Failed to get information about all PDP contexts
Tue Jan 31 21:13:46 2023 daemon.info mobifd: [gsm.modem0] APN '' isn't prepared for PDP 1, preparing it
Tue Jan 31 21:13:47 2023 daemon.err mobifd: [gsm.modem0] Failed to set PDP 1 context
Tue Jan 31 21:13:47 2023 daemon.err mobifd: [gsm.modem0] Failed to insert '' APN
Tue Jan 31 21:13:47 2023 daemon.info mobifd: Failed to prepare connection for "gsm.modem0". Waiting 0 seconds
...

Btw: While modem-fw update I got some of these  bad-block-messages, maybe this could be a/the problem?

[004.971]: <erase PAGES_PER_BLOCK="64" SECTOR_SIZE_IN_BYTES="2048" num_partition_sectors="29696" physical_partition_number="0" start_sector="120576"    />[004.973]: <log value="start_sector = 120576 and num_partition_sectors =0x7400)"/>
[005.478]: <log value="Skipping:        bad block 0x8b0"/>
[005.661]: <response value="ACK" />

With new modem-fw it's possible each time when a sim-switch is hanging to release again by "gsmctl --reboot".

by anonymous

Hello,

  

Flash on your device seems to pass all checks, so it should not be an issue.

I'd like you to generate one last troubleshoot file, and I'll contact our RnD team.

For now, if you have frequent SIM switches, I'd recommend configuring ping reboot (Services → Auto Reboot → Ping/Wget Reboot). Set it to reboot the modem if the connection is lost.

  

Best regards,
DaumantasG

by anonymous

Thx, in my scenario a hanging modem could only be avoided if every "ubus call sim change" have a prefixed "gsmctl --reboot; sleep 10".

Rebooting modem mostly releases a modem-hang - BUT it does not reset the timer for the sim-switch rules.
But an "ubus call sim change" or a modem-restart an already started sim-switch-rule does NOT stoppt/reset sim-switch-timer for this sim-slot - so the timer continues and fires a failover despite sim has been already switched by "ubus call sim change" (message in logger is: "SIM switch in progress. Triggered by data_fail rule").

I disabled now sim-switching at all and implemented own checks that reset the timer each time an "ubus call sim change" happens.

BR Rainer