FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
930 views 15 comments
by anonymous
Once a day, the RUTX50 loses the 5G connection and has only 3G.

Even after connection restart, it no longer connects to 5G.

Only when the router is rebooted everything does work normal again.

Reception is available all the time without any problems.

The data consumption has also increased from 20GB (RUT950) to approx. 85GB (RUTX50). Even I am still working the same hours in the same role.

 What could be the reason for this?
by anonymous
1. Leaving router on 4G+5G results in not h
by anonymous
Hello,

  

Have you tried ping reboot and setting network mode to 4G +5G as suggested in the last message?

The router uses carrier configuration for Vodafone Germany, this does not necessarily indicate an issue, but it's worth trying.

As for logging into CLI, this is a normal Linux behavior and it is the same on all Linux machines. Simply enter your password and press enter. If you see a RutOS banner, you've successfully logged in!

  

Best regards,
DaumantasG

2 Answers

0 votes
by anonymous

Hello,

  

It's hard to say what could be the cause. Most carriers use 5G non-standalone (NSA), which works, by the device connecting to 4G and 5G networks at the same time. So your device falling back to 3G is most likely caused by a loss or disconnection from the 4G network, not 5G.

It would be great if you could generate two troubleshoot files: one when the 5G is operational and another when the device has fallen back to 3G.
These files can be generated by navigating to System → Administration → Troubleshoot. They can be attached to the original post and will only be visible to Teltonika moderators.

  

Regarding the data consumption, are you getting these numbers from your mobile operator or are they from the router itself?

  

Awaiting your response!

Best regards,
DaumantasG

by anonymous
Thanks for your reply.

I managed to get two reports. One while connected to 5G and one while connected to 3G.

Which file exactly do you want me to upload?

I also noticed that the time the connection downgrades from 5 to 3G is almost the same. Between 3 am 4pm.

Regarding consumption, I get these numbers from the router.
by anonymous
Hello,

  

I'd like you to upload both .tar.gz files. There are a few things of interest in multiple files.

If it happens around the same time it might be operator related, but it's hard to tell without looking at the logs first.

  

Best regards,
DaumantasG
by anonymous
Hi,

I have uploaded both files.
Please let me know if you need anything else.

Best regards
by anonymous

Hello,

  

Thank you for the information!

I can indeed see the mob1s1a1 (9264): Mobile connection lost! message in the logs.

Could you try setting the router to 4G+5G network mode only and seeing how this behavior changes? This can be done by navigating to Network → Mobile → General and setting the network type to 4G + 5G.

Awaiting the results!

   

Best regards,
DaumantasG

by anonymous
Hi,

indeed it looses 5G connection (down to 3G) everyday 5-10 min after 3pm.

I changed to setting 4G+5G with the result that it can't connect at all anymore shortly after 3pm. (Which is clear as only 4G and 5G are allowed.)

When rebooting the device its working normal again.

Also my phone does not loose 5G connection. Thus I think my phone provider is not the problem.

Must be a router bug.

Or maybe the router itself?
by anonymous

Hello,

  

For now, I'd recommend leaving the router on 4G+5G-only mode and setting up a ping reboot with the Action set to Modem reboot. This will cause a minimal impact on the operation of the router and connection will only be lost for around 5-8 seconds. If this does not help, Action could be set to Device Reboot, however, this is most likely not needed.

One more thing that could be tried, is the firmware upgrade using the bootloader method. This will ensure that all of the files on the router are re-written and will remove any misconfigured files if there are some left over from the upgrade. Even if you have the latest firmware (RUTX_R_00.07.03.3), it can be installed and it will be a "hard factory reset".

As our RnD department is constantly improving our 5G products, let's hope this issue will be fixed with the v7.4 firmware release of RutOS, which should come out in around a month. If the behavior is the same after the update, please contact me via private message and I'll relay your information to our RnD team.

We apologize for any inconvenience caused.

  

Best regards,
DaumantasG

by anonymous

Actually, one more thing we could try is selecting a different MBN option. This is related to the mobile operator, and I can see that your router selected German Vodafone as the carrier, even though you're not even in Germany.

First, log in to the router using CLI/SSH (username root, password the same as WebUI), then run this command:

gsmctl -A 'AT+QMBNCFG="Select","ROW_Generic_3GPP_PTCRB_GCF"'

Then wait for the next day, and if the issue repeats, these changes can be reverted by running this command:

gsmctl -A 'AT+QMBNCFG="AutoSel",1'

Also, if the issue is not solved, could you generate a troubleshoot file after the router loses connection when locked in the 4G + 5G mode?

Let me know if it helps.

  

Best regards,
DaumantasG

by anonymous

1. Leaving router on 4G+5G results in not having any internet connection. As router daily resets in 3G mode. 

2. Carrier is Vodafone Spain. Where do you have the Vodafone Germany? Router was bought at German supplier.

3. Can not run command: gsmctl -A 'AT+QMBNCFG="Select","ROW_Generic_3GPP_PTCRB_GCF"'

After I enter "root", I can not enter my password. When typing nothing appears on screen. 

4. Last thing I haven't tried is the bootloader method. Will try upcoming weekend. 

The whole issue is very annoying!

0 votes
by anonymous
I have set an automatic device reboot schedule everyday at 2am.

But no ping reboot. Dont even know what this does.

Yes, I set it to 4G+5G with the result that I have no internet connection because it only connects 3G.
by anonymous

Ping reboot can be configured by navigating to Services → Auto Reboot → Ping/Wget Reboot. This feature sends out pings at pre-determined intervals, and if it does not receive a specified amount of responses, it executes an action (in this case, a modem reboot).

In your case, the configuration could look like this:

This, of course, can be customized, but it will only work in this case if the Service mode is set to 4G + 5G, as that is the only case where the device will lose the internet connection.

A scheduled reboot is not needed in this case, as the issue seems to be related to the operator.

  

Best regards,
DaumantasG

by anonymous
I dont think the issues are related to the operator, cause everytime it happens and I reboot device it works without any problems.

I will do to boatloader method and let you know.

Please get a firmware update asap!
by anonymous

Have you tried the command specified in one of my previous replies (gsmctl -A 'AT+QMBNCFG="Select","ROW_Generic_3GPP_PTCRB_GCF"')?

  

Best regards,
DaumantasG

by anonymous
Yes, but didn't change anything. Unless the loss of 5G connection is now short after 2pm and not 3pm.
by anonymous
Some improvements were done with v7.4, so let's see if the update helps. It should come out in around a month.

Let me know if it does not help.

  

Best regards,
DaumantasG