FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
376 views 6 comments
by anonymous
I am trying to setup multiple Wireguard VPN instances.
But only one instance appears in routing, and the second instance won´t do handshake.

Any idéas?

Kind regards

Lars-Erik

1 Answer

0 votes
by anonymous

Hello,

There is no reason why your setup cannot be set to work. What are you trying to do:

  1. One wg server interface and multiple outside clients
  2. or multiple wg server interfaces, one for each client ?

Regards,

 

by anonymous
I´m setting up separate VLAN for each customer in a hosted envirionment (so far only test environment).

Each customer shouldn´t be able to access each other, and that is working with VLAN-separation.

Each customer should have their own WG-interface so that it´s not only an IP-configuration on customer side that is stopping them from accessing another customer VLAN.

From start RUTX09 added both interfaces to the same zone. So I separated the wireguard interfaces.

With the wg-interfaces separated in zones only one interface appears in the routing table.

Regards
Lars-Erik
by anonymous

With the wg-interfaces separated in zones only one interface appears in the routing table.

Could you be be more precise ? What is the output of ifconfig ? Of ip -4 route show ?

by anonymous


Enabled the second instance and my first instance WGFAL doesn´t show in routing table.
default via xxx.xxx.xxx.xxx dev eth1 proto static src xxx.xxx.xxx.xxx metric 1
default dev wwan0 proto static scope link src 100.79.109.206 metric 2
10.0.10.0/24 dev WGDala proto kernel scope link src 10.0.10.1
10.0.10.3 dev WGDala proto static scope link
100.79.109.206 dev wwan0 proto static scope link metric 2
192.121.58.0/24 dev eth1 proto static scope link metric 1
192.168.20.0/24 dev br-lan proto static scope link metric 5
192.168.30.0/24 dev eth0.30 proto static scope link metric 7
192.168.40.0/24 dev eth0.40 proto static scope link metric 8
by anonymous
Found the issue! :)

Both instances was running on the same listen port.

Changed to 51821 on the second instance and both instances are up and running!

Time to check out for the weekend. :)
by anonymous
That's a good enough reason for failure!
by anonymous
Yes for sure!
And of course the firewall rule had to be edited, and the new port included.

Thanks for helping me think a little. ;)