FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
629 views 15 comments
by anonymous
Hello guys and girls,

for multiple days now, I am trying to set up a RUT955 as part of a student project. It is needed to establish a remote access to the router and later to the connected PLC. I have done literally everything that any guide/video/user manual tells me to do, to set up the remote connection to the router, via DynDNS. DynDNS is definitly working (tested on different router).

System log says it fails to get the local IP, but I just can't understand why this is happening.

Troubleshoot file is attached!

This is the system log record:

Mon Jan 23 11:20:15 2023 user.warn ddns-scripts[27811]: dynDNS: Get local IP via network failed - retry 50/0 in 60 seconds

Mon Jan 23 11:21:16 2023 user.err ddns-scripts[27811]: dynDNS: network_get_ipaddr Error: 1

Thanks for helping :)

2 Answers

0 votes
by anonymous

Hello,

There might be a few possible issues here:

  • Try selecting the IP address source as Custom and choosing the interface you'd like to reach the router via:
     

  • Currently you have selected the interface WAN, however, I can see that at the moment of generating the troubleshoot file, you did not have a wired Ethernet connection, and were only using a mobile connection. So the IP source should be mob1s1a1
  • You also seem to have a private IP address assigned by the carrier, so unless a private APN is in use, the device will not be reachable over the internet. Make sure your carrier does not require a custom APN to be used to acquire a public IP.
  • If this does not help. then there also seems to be multiple DDNS packages installed on your device. This may cause the service to crash. To remove the unused instance, run this command:

opkg remove ddns-opkg

Let me know if neither of these options helps!

Best regards,
DaumantasG

Best answer
by anonymous
Would you be able to check what APN was in use with your last device?
by anonymous
old APN: telekom.t-d1.de -> looks like this is an APN that gives you a public IP, but can officially only be used for test reasons

I am now using this APN with the teltonika RUT955 -> Connection is established, Wi-Fi running and RMS is working too, BUT DynDNS is stil not working. New troubleshoot file can be found in the original post
by anonymous

Hello,

  

Indeed, public IP is now available for the mobile interface.

However, I can see that you're still using interface WAN to acquire the IP address. Please change it to mob1s1a1 and try again.

EDIT: I also noticed, that your ISP is giving out the DNS servers with private IP addresses. This will most likely result in DNS not working. Custom DNS servers can be added to the mob1s1a1 interface, in the Advanced settings. Google or Cloudflare DNS servers could be used (1.1.1.1 or/and 8.8.8.8).

  
Best regards,
DaumantasG

by anonymous
Unbelievable...everything is working now! Thank you so much for your patience. I really feel like a grandma now, but thank you so much for your help! :)
by anonymous
Glad I could help! :)

  

Best regards,
DaumantasG
0 votes
by anonymous

Hello,

It would be helpful if you could provide a troubleshoot file. Please, replicate the issue, by setting your configuration, then access router's WebUI, go to System -> Administration -> Troubleshoot section and download troubleshoot file from there. The logs in the file might provide more insight into the issue, it will also let to review your configuration details.

Best regards,

by anonymous
File is attached :)