FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

13390 questions

15918 answers

25772 comments

50540 members

0 votes
43 views 2 comments
by
I was just troubleshooting one RUT955 to figure out why even though all of the required data points are

being read in Modbus TCP ok, and yet only 2 of 11 points are sent up to thingsboard.
The other 5 systems with identical configurations are working fine...

Anyway, I noticed that on a system which has just been SIMmed and configured today, it has burned 150MB of  data.
That seems obscene!
about 50MB is Tx and 100MB is Rx

WTH is sucking all that bandwidth ?
Are there any tools  to zero in on the per-process network-burn ?
Are there well-known network-pig processes which can be shut down ?
 

I have noticed this along the way on all these 955 systems, but have remained focused on nailing down basic functionality before optimizing for network burn.
Remote RMS has been left turned off.
We're not watching any videos ;-)

To my mind the network burn-rate should be ZERO - except for the specific IoT transactions we are configuring.

1 Answer

0 votes
by

Hello,

Did you have a public IP and remote SSH/HTTP access enabled?

For a very basic view of currently active connections, WebUI has a Status -> Realtime Data -> Connections monitoring window.

A more detailed connections and traffic data can be obtained by installing Darkstat package. You can install it with the following commands:

  • opkg update
  • opkg install darkstat
  • /etc/init.d/darkstat enable
  • /etc/init.d/darkstat start

Then open your browser and enter routers IP with added 667 port. For example:

  • 192.168.1.1:667

Host section can provide quite detailed statistics on each IP address monitored by the application.

Alternatively, you can install TCPdump from Services -> Package manager and enable monitoring for mobile wwan0 (mob1s1a1_4) interface and download the file later from the same page.

Best regards,

by
Thank you...
No public IP

Based on an initial look at the connections page there seems to be 80 connections and a continuous stream of packets between the

mobile IP and our corporate network...
I remember when monkeying around with this at home I could tell that when I had the ethernet connected for comms to the RUT

all of my regular computer traffic seemed to get routed through the RUT rather than wifi

I set my ethernet connection to metered connection in Windoze and also made the address static at 192.168.1.99

and specified no gateway so I thought that ought to be sufficient...
Now I suspect that somehow my laptop may be preferentially routing through the RUT ??

I did look at the RUT router config to just disable routing from wwan to ethernet, and had our IT look at it.
I can normally figure out the routing stuff in other gateways... but the RUT has me baffled as to how to just

prevent any routing - which should not happen anyway if 192.168.1.1 is not pointed to as a gateway

I've got both Darkstat and TCPdump installed...
I didn't get any smarter looking at the darkstat graphs and am not clear how to tell TCPdump to monitor/log

the wwlan0 traffic...

I'm bagged, going home ;-)

I'm not clear on how to
by

If you have your computer connected to wired and wireless networks, maybe a wired interface takes precedence over the wireless one?

Could you try changing the metrics of interfaces within your computer, as in example below:

Darkstat and tcpdump are simply for determining sources of undesired traffic.

Best regards,