FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
187 views 4 comments
by anonymous
Hello,

I am using an RUT955 router to monitor a plant via a 4G mobile connection. The rooter acts as an OpenVPN client.

Every day the mobile data connection disconnects itself and connects back with a different IP given by the provider.

After this event the router is not able to reconnect to the OpenVPN server. Here is the error message from the OpenVPN server, generated every 6 minutes :

*****************

 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Feb  1 00:00:22 vps472625 ovpn-myserver[10851]: IPxxx TLS Error: TLS handshake failed
Feb  1 00:00:22 vps472625 ovpn-myserver[10851]: IPxxx SIGUSR1[soft,tls-error] received, client-instance restarting

******************

I have to reboot the RUT955 via SMS to be able to regain the connection. How can I solve this please ?

Best regards,

Julien

1 Answer

0 votes
by anonymous

Hello,

The device should recover by itself without any additional input in scenarios like this.

I would like you to attach a troubleshoot file to your question. Please, replicate the issue, then access router's WebUI, go to System -> Administration -> Troubleshoot section and download troubleshoot file from there. The logs in the file might provide more insight into the issue.

Attached files are private and visible only to Teltonika Moderators.

Best regards,

by anonymous
Hello,

Here is the troubleshoot file.

Best regards,

Julien
by anonymous
Hello,

Actually the complete Internet connection is lost after the change of IP from the mobile data provider.

Any suggestions ?

Best regards,

Julien
by anonymous

Hello,

The issue might then be related to mobile connection loss.

Could you try the following:

  • Login to router's WebUI, navigate to Services -> Ping/Wget reboot -> Auto reboot.
  • Edit existing default or create a new instance.
  • Enable it.
  • Set Action if no echo is received to Modem reboot.
  • Interface: Ping from mobile.
  • Edit Host to ping if necessary.

Otherwise, I do not see the troubleshoot file. Could you forward it in a private message?

Best regards,

by anonymous
Hello,

I updated to the latest firmware and now the connection doesn't get lost.

Thanks for your help,

Julien