FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
560 views 24 comments
by anonymous

Dear all,

I am trying to setup a RUT955 as server in my sailboat. The aim is to connected my Radar system to my Windows tablet using Wifi. Via the Raymarine (radar manufacturer, I know some people succeeded in interfacing the Classic E80 to a tablet via a wireless connection, however I think I run into my network limitations for the RUT955 and need some help setting the unit up correctly.

When I connect the computer via LAN, the system works, but not on the wifi

From the Raymarine forum, I got the following guide which I have tried to follow

3. Get a wireless router. Most will work but you want to select a model where you can configure the routing tables manually. The E80 has a fixed IP address (shown in the menu's) - for example, 10.0.59.173 (mine is 10.0.154.40). Once it is booted, it starts checking the network starting with 10.0.0.1 upwards. Thus, you want to configure the router with a gateway of 10.0.0.1 and the tablet that connects over Wifi as 10.0.0.2 or above. Raymarine recommends 10.0.0.7, you can use any address in that subnet. Make sure it does not conflict with any other devices you have. Then you setup a fixed route between the E80 (10.0.59.173 in my case) and the tablet (10.0.0.2 in my case). First you power on the router, then start the Raytech RNS sofware on the tablet, then cycle the power on the E80. The E80 will investigate the network and find the RNS software. You do not need to use the Raymarine network utilities as you have set fixed addresses already.

So my question is how do I set up this fixed route?

Thanks, Mark

1 Answer

0 votes
by anonymous
Hello,

Could you describe how you have configured your RUT955 and how you have connected the E80 to it ?

You can search the forum for "Raymarine" there is already several solutions described on how to connect it to the rest of the world.

Regards,
by anonymous

I have used the 255.0.0.0 as sub masknet

So you have put everything in the same network, the arp layer is tasked with discovering where 10.0.154.40 is.

No need for ifconfig output anymore. To access it, connect to the router via ssh or CLI, the user is root and same password as the UI.
 
by anonymous

Do I understand correctly the way to fix the SSID issue is to go in via ssh or CLI?

Can you guideme through that, never done that before

Thanks

by anonymous
I would like to have a full picture of the addresses in use at the router side, for that from the UI go to System->Administration->Access control and enable CLI. Then go to System->CLI, the user is root and the passwd is the same as the one of the UI. From this point you can enter commands, ifconfig will be the first one to execute.

Another way is to install putty or openssh on the PC and connect to the router. Same user/password and same commands.
by anonymous
Ok this what I get:

  |  _ \ _   _| |_ / _ \/ ___|                                             

  | |_) | | | | __| | | \___ \                                             

  |  _ <| |_| | |_| |_| |___) |                                            

  |_| \_\\__,_|\__|\___/|____/                                             

                                                                           

 ---------------------------------                                         

   Teltonika RUT9 series 2022                                              

 ---------------------------------                                         

root@Teltonika-RUT955:~# ifconfig                                          

br-lan    Link encap:Ethernet  HWaddr 00:1E:42:4B:85:01                    

          inet addr:10.0.0.1  Bcast:10.255.255.255  Mask:255.0.0.0         

          inet6 addr: fe80::21e:42ff:fe4b:8501/64 Scope:Link               

          inet6 addr: fdbb:ac84:6a36::1/60 Scope:Global                    

          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1               

          RX packets:46492 errors:0 dropped:0 overruns:0 frame:0           

          TX packets:44685 errors:0 dropped:0 overruns:0 carrier:0         

          collisions:0 txqueuelen:1000                                     

          RX bytes:9656623 (9.2 MiB)  TX bytes:30652521 (29.2 MiB)         

                                                                           

eth0      Link encap:Ethernet  HWaddr 00:1E:42:4B:85:01                    

          inet6 addr: fe80::21e:42ff:fe4b:8501/64 Scope:Link               

          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1               

          RX packets:19211 errors:0 dropped:0 overruns:0 frame:0           

          TX packets:13320 errors:0 dropped:0 overruns:0 carrier:0         

          collisions:0 txqueuelen:1000                                     

          RX bytes:11635092 (11.0 MiB)  TX bytes:1421970 (1.3 MiB)         

          Interrupt:5                                                      

                                                                           

eth0.1    Link encap:Ethernet  HWaddr 00:1E:42:4B:85:01                    

          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1               

          RX packets:19211 errors:0 dropped:0 overruns:0 frame:0           

          TX packets:13312 errors:0 dropped:0 overruns:0 carrier:0         

          collisions:0 txqueuelen:1000                                     

          RX bytes:11289294 (10.7 MiB)  TX bytes:1367826 (1.3 MiB)         

                                                                           

eth1      Link encap:Ethernet  HWaddr 00:1E:42:4B:85:02                    

          UP BROADCAST MULTICAST  MTU:1500  Metric:1                       

          RX packets:0 errors:0 dropped:0 overruns:0 frame:0               

          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0             

          collisions:0 txqueuelen:1000                                     

          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)                           

          Interrupt:4                                                      

                                                                           

lo        Link encap:Local Loopback                                        

          inet addr:127.0.0.1  Mask:255.0.0.0                              

          inet6 addr: ::1/128 Scope:Host                                   

          UP LOOPBACK RUNNING  MTU:65536  Metric:1                         

          RX packets:276 errors:0 dropped:0 overruns:0 frame:0             

          TX packets:276 errors:0 dropped:0 overruns:0 carrier:0           

          collisions:0 txqueuelen:1000                                     

          RX bytes:23828 (23.2 KiB)  TX bytes:23828 (23.2 KiB)             

                                                                           

wlan0     Link encap:Ethernet  HWaddr 00:1E:42:4B:85:03                    

          inet6 addr: fe80::21e:42ff:fe4b:8503/64 Scope:Link               

          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1               

          RX packets:50840 errors:0 dropped:0 overruns:0 frame:0           

          TX packets:66296 errors:0 dropped:0 overruns:0 carrier:0         

          collisions:0 txqueuelen:1000                                     

          RX bytes:10398683 (9.9 MiB)  TX bytes:44302449 (42.2 MiB)        

                                                                           

wwan0     Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-

00-00-00                                                                   

          inet addr:10.181.196.230  P-t-P:10.181.196.230  Mask:255.255.255.

255                                                                        

          inet6 addr: fe80::755:2887:d71c:f264/64 Scope:Link               

          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1       

          RX packets:42313 errors:0 dropped:0 overruns:0 frame:0           

          TX packets:34854 errors:0 dropped:0 overruns:0 carrier:0         

          collisions:0 txqueuelen:1000                                     

          RX bytes:29644595 (28.2 MiB)  TX bytes:8438284 (8.0 MiB)         

                                                                           

root@Teltonika-RUT955:~#
by anonymous

With br-lan set to 10.0.0.1/8 you have a partial conflict with wwan0 in 10.181.196.230/32.

What is the output of:

  1. ip -4 route show
  2. ip -4 rule show
  3. arp

IMO it would be simpler to set br-lan to 192.168.1.1/24 or similar, and incremenrally solve the E80 and tablet issues.