FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
435 views 4 comments
by anonymous
Hi, documentation on Data to server Retry on fail functionality is very limited. What is this feature supposed to do? I have turned it on and then I simulated some connection problems and responded with 400, 403, 500 return codes when datasender tried to send. So far I have never seen it retry, it will just skip the data that was not successfully sent and continues with fresh data after connection is working.

1 Answer

+1 vote
by anonymous
Hi,

I am sorry that there is not enough documentation regarding this option. I will try to explain it here.

The way 'Retry of fail' option works in 'Data to Server' is that if the server is unreachable, then it will collect source data (for example, Modbus data) and will try to send it on the next retry, depending on the configured interval. If the second try fails, it will continue to store data and will try again until it will be able to reach the server.

Now, this refers to the TCP/IP connection and not the HTTP response code. It does not matter if the server returns 200,400, or 404. The router was able to connect to the server, so it considers it a success and will not store the data. If the server is down or the link is down, then the server is unreachable and the device will start storing data.

Kind Regards,

Andzej
Best answer
by anonymous
Hi, thank you for responding. I have Retry on fail ON. It doesn't seem to work for me. I tried two platforms to check both didn't work:

On Azure and as an IOT Device and Also on Machine Advisor by Schneider Electric.

https://community.teltonika-networks.com/?qa=blob&qa_blobid=18074001817007004543
by anonymous

Hi,

Would it be possible for you to provide more details? Could you provide any logs of the received data in Azure?

Also, could you replicate the issue and generate a troubleshoot file, please? Troubleshoot file can be downloaded from System -> Administration -> Troubleshoot.

Kind Regards,

Andzej

by anonymous
Hi,

Could you please attach a troubleshoot file? It is hard to make sense of these logs as I do not know the configuration. I need to see the configuration to know when and what data is supposed to be sent. Thanks.

Kind Regards,

Andzej