FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
390 views 10 comments
by anonymous

hello All,

After to upgrade my TRB140 on TRB1_R_00.07.03.2 by server or by file, I lost internet if I use bridge mode on TRB140.

ALL is OK  if I downgrade to  TRB1_R_00.07.02.7 | 2022.09.12

Can you help me ?

Best Regards

Anthony

1 Answer

0 votes
by anonymous

Hello,

I would be helpful if you could to attach a troubleshoot file to your question from the device with the issue.

Please, replicate the issue, then access router's WebUI, go to System -> Administration -> Troubleshoot section and download troubleshoot file from there. The logs in the file might provide more insight into the issue.

Best regards,

by anonymous
Hello,

I added to ticket

best Regards

Anthony
by anonymous

In the file ARP entry is for some reason incomplete.

Could you login to your router via SSH and try the following command:

  • ip neighbor replace <mobile_public_IP> lladdr <mac_address_of_connected_device> dev br-lan

For comparison, could you also attach a troubleshoot file from the router with 7.02.7 firmware and a properly working bridge mode?

Best regards,

by anonymous
Hello,

root@Teltonika-TRB140:~# ip neighbor
46.247.171.42 dev br-lan lladdr 08:92:04:95:66:93 REACHABLE
192.168.2.208 dev br-lan lladdr 16:d7:bf:39:30:ad REACHABLE

root@Teltonika-TRB140:~# ip neighbor replace 46.247.171.42 lladdr 08:92:04:95:66:93 dev br-lan
root@Teltonika-TRB140:~# ip neighbor
192.168.2.208 dev br-lan lladdr 16:d7:bf:39:30:ad REACHABLE
46.247.171.42 dev br-lan lladdr 08:92:04:95:66:93 PERMANENT

Now I have Internet with TRB1_R_00.07.03.2

for TRB1_R_00.07.02.7 :

root@Teltonika-TRB140:~# ip neighbor
fe80::f9a1:f2a4:260c:ede1 dev br-lan lladdr ba:cb:3d:e1:74:19 STALE
fe80::8be2:a8af:e420:3473 dev br-lan lladdr ba:cb:3d:e1:74:19 STALE
fe80::40fb:23c7:e2e8:5b0f dev br-lan lladdr 08:92:04:95:66:93 STALE
192.168.2.130 dev br-lan lladdr ba:cb:3d:e1:74:19 REACHABLE
192.168.2.188 dev br-lan lladdr 08:92:04:95:66:93 STALE
46.247.171.42 dev br-lan lladdr 08:92:04:95:66:93 REACHABLE

I have internet allways without coammnd modify ip neighbor replace in cli
by anonymous
Hello,

If I understand correctly, the above suggestion did work?

Best regards,
by anonymous

Hello,

in TRB1_R_00.07.03.2 with bridge mode :

  • yes when I add "ip neighbor replace 46.247.171.42 lladdr 08:92:04:95:66:93 dev br-lan" in cli internet was OK
but I do not understand why I have to make this CLi command when before it was not necessary
Best Regards
Anthony
by anonymous
I added to my first message troubeshoot file

Best Regards

Anthony
by anonymous
Thank you for additional file.

I am unable to provide the answer at the moment, but I have forwarded the question to the development team.

Hopefully, they will provide more insight into why 7.3.2 requires manual adjustments.

Best regards,
by anonymous

Hello,

have you received any feedback from R&D support?

Best Regards

Anthony

by anonymous

Hello,

Not sure if that explains anything, but below is the only message from RnD:

  • Issue occurred only on TRB1 with APN's where Gateway IP was BridgeIP - 1. APN's where Gateway IP was BridgeIP + 1 worked properly.

Aside from that, software changes were needed. The solution is merged to 7.4 firmware, which should be released by the end of the next week. 

Best regards,

by anonymous

Hello ALL,

Problem is solved with :

Thank you

Have good days

Best Regrads

Anthony