subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
232 views 3 comments
by anonymous
I have read and executed upon the advise found on similar threads.
here i have Starlink on the WAN link eth1 - i also tried starlink wia wifi

Both worked at some point, and after a couple of days just stopped working. I checked the router and found the wan link does no longer have an IP address. And no matter what i do, i dont regain one from Starlinks dhcp service.

i have questons:
Whats the fix? How can i force a dhcp renewal from the commandline?

1 Answer

0 votes
by anonymous


This seems more like an issue on the provider's side, but you can try to initiate DHCP renewal.

Login to the router via SSH first. Enter the following command to find the ID of udhcp process:

  • ps | grep dhcp

Look for a process similar to the one below with eth1.

  • udhcpc -p /var/run/ 

The enter the following command:

  • kill -SIGUSR1 <ID>

Replace <ID> with the value shown by command above.

In parallel you can have another SSH instance opened running command: 
  • logread -f

This will help to determine, whether the lease gets renewed immediately by providing the logs output.

Otherwise, I would like you to attach a troubleshoot file to your question. Please, replicate the issue, then access router's WebUI, go to System -> Administration -> Troubleshoot section and download troubleshoot file from there. The logs in the file might provide more insight into the issue.

Best regards,

by anonymous
I also have this exact issue, turn my Starlink off, power it back on and Teltonika never gets a DHCP address again. Reboot 955 and all is fine.

Log read shows a broadcast go out if I kill the process but thats it, nothing else ever comes back.
by anonymous


Without additional information, it is difficult to estimate the cause of it.

Could you generate a troubleshoot file, as requested above, after IP lease expires and no renewal occurs?

Enabling packet capture on router's WAN interface with TCPdump might also be useful, with an approximate timestamp, when no IP is provided. TCPdump can be downloaded from router's WebUI Services -> Package manager page and enabled from System -> Administration -> Troubleshoot page. 

Is there any possibility to get logs from Starlink side during the same time frame?

Best regards,

by anonymous
i did create a troubleshooting file, and i replied to the email i got.

-- for the other victims, i may have found a workaround - i put a desktop switch in between starlink and the rtu950
then i rebooted like an idiot both revices in random orders until finally i had an ip back.

Since that desktop switch is in between, i no longer seem to lose the IP, and the failover procedure works.

This is a workaround, no solution.   I also opened a ticket with starlink, they did not bother to reply to me yet.
Kudos to the teltonica team, who usually respond fast and dont take a user for a fool.
(starlink initial response was to power off/on  - i kid you not. I work 30+ years in enterprise IT, and i have to put up with that...)