FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
237 views 3 comments
by anonymous
Trying to get a (new) Rutx50 to work on firmware version RUTX_R_00.07.03.3. When applying the config (uci commands), the mobile interface won't come up. When I browse to Network / Mobile / General I get an 404 page not found error, and on overlay I get the "failed to load modem status" message. Attached is the troubleshoot file.

1 Answer

0 votes
by anonymous

Hello,

Could you specify the uci commands you have used to configure the router?

Does the modem respond under default configuration?

The issue seems to rise from SIM switch configuration. For some reason the device fails reading configuration details. Have you made any changes to this functionality with uci?

At the moment, logs indicate SIM PIN requirement. Since Network -> Mobile -> General is not accessible over WebUI, could you login via SSH and enter this value?

Best regards,

Best answer
by anonymous
Here are the simcard and sim_switch commands used. I've created these based on our Rutx9 router and assumed these would work on the Rutx50 as well.

uci set sim_switch.@sim[0]=sim

uci set sim_switch.@sim[0].modem='3-1'

uci set sim_switch.@sim[0].position='1'

uci set sim_switch.@sim[0].enabled='1'

uci set sim_switch.@sim[0].on_signal='1'

uci set sim_switch.@sim[0].data_limit='0'

uci set sim_switch.@sim[0].sms_limit='0'

uci set sim_switch.@sim[0].roaming='0'

uci set sim_switch.@sim[0].no_network='1'

uci set sim_switch.@sim[0].denied='1'

uci set sim_switch.@sim[0].fail_flag='0'

uci set sim_switch.@sim[0].interval='10'

uci set sim_switch.@sim[0].retry_count='3'

uci set sim_switch.@sim[0].weak_signal='-85'

uci set sim_switch.@sim[1]=sim

uci set sim_switch.@sim[1].modem='3-1'

uci set sim_switch.@sim[1].position='2'

uci set sim_switch.@sim[1].enabled='1'

uci set sim_switch.@sim[1].on_signal='1'

uci set sim_switch.@sim[1].data_limit='0'

uci set sim_switch.@sim[1].sms_limit='0'

uci set sim_switch.@sim[1].roaming='0'

uci set sim_switch.@sim[1].no_network='1'

uci set sim_switch.@sim[1].denied='1'

uci set sim_switch.@sim[1].fail_flag='0'

uci set sim_switch.@sim[1].enable_back='1'

uci set sim_switch.@sim[1].interval='10'

uci set sim_switch.@sim[1].retry_count='3'

uci set sim_switch.@sim[1].weak_signal='-85'

uci set sim_switch.@sim[1].switch_back='3'

uci set simcard.@sim[0].modem='3-1'

uci set simcard.@sim[0]=sim

uci set simcard.@sim[0].position='1'

uci set simcard.@sim[0].primary='1'

uci set simcard.@sim[0].auto_apn='1'

uci set simcard.@sim[0].volte='auto'

uci set simcard.@sim[0].deny_roaming='0'

uci set simcard.@sim[0].operlist='0'

uci set simcard.@sim[0].enable_sms_limit='0'

uci set simcard.@sim[0].service='auto'

uci set simcard.@sim[0].pincode='0000'

uci set simcard.@sim[0].band='auto'

uci set simcard.@sim[1]=sim

uci set simcard.@sim[1].modem='3-1'

uci set simcard.@sim[1].position='2'

uci set simcard.@sim[1].auto_apn='1'

uci set simcard.@sim[1].volte='auto'

uci set simcard.@sim[1].primary='0'

uci set simcard.@sim[1].deny_roaming='0'

uci set simcard.@sim[1].operlist='0'

uci set simcard.@sim[1].enable_sms_limit='0'

uci set simcard.@sim[1].service='auto'

uci set simcard.@sim[1].pincode='0000'

uci set simcard.@sim[1].band='auto'

I gave the device a factory default, pasted our uci command template and let the device reboot. This is the first Rutx50 we're deploying.
by anonymous

Found the issue.Both in "simcard" and "sim_switch" commands, I have the "modem" suboption that is different from the Rutx09 vs Rutx50. I've removed those from my template (let the router default setting as is) and the router works just fine now.

uci set sim_switch.@sim[0].modem='3-1'
uci set sim_switch.@sim[1].modem='3-1'

uci set simcard.@sim[0].modem='3-1'
uci set simcard.@sim[1].modem='3-1'
 

by anonymous

Hello, I have checked with the RUTX50, and, I think, the issue is the modem ID.

In your case you set uci set simcard.@sim[1].modem='3-1'

It should be 2-1.

Please try replacing this value for both SIMs, see if that helps.

Best regards,