FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
600 views 7 comments
by anonymous
When I try to save & apply anything in the section Administration/Access control the error "Server certificate and Server key are both requiered" occurs. Even when i don't change anything, just try to save the default setting, this happens.

I have the newest firmware installed and it appears on all RUT240, so it can't be a specific problem.

Can somebody help or is it a software problem?

Thank you!

2 Answers

+1 vote
by anonymous

Hello,

Could you provide the following details?

Which exact firmware version did you have before performing an update?

Did you update with Keep settings option set to on?

Could you reset one of your devices to factory default settings and check, if the issue is still present?

If reset does help, I would like you to attach a troubleshoot file to your question. Make sure the issue is present, then access router's WebUI, go to System -> Administration -> Troubleshoot section and download troubleshoot file from there. The logs in the file might provide more insight into the issue.

Attached files are private and visible only to Teltonika Moderators.

Best regards,

Best answer
by anonymous

I had the RUT2XX_R_00.01.14.6 version before. I updated with keep settings.

The reset didn't solve the problem.

I tried it on 3-4 different RUT 240 and it's always the same problem, so i think it has nothing to do with my settings.

When i create certificates and keys to put them in the requierd fields, it also changes nothing.

by anonymous
As requested, please attach a troubleshoot file from one of affected devices by editing your original question.

Best regards,
by anonymous

The developers are aware of the issue. No solution is available yet at the moment.

Could you try downgrading to RUT2_R_00.07.03.3 with Keep settings set to off and see if the issue persists?

Also, what specific changes do you want to perform? Some of them could be done over CLI/SSH.

Best regards,

by anonymous
I downloaded the older firmware with the old interface, now it's working.
I want to activate the remote acces via http and https.
by anonymous

Over SSH remote HTTP(S) access can be enabled by editing firewall configuration file, by adding additional option to Enable_HTTP_WAN and Enable_HTTPS_WAN rules. That option is:

  • option enabled '1'

To enter the configuration file, access router via SSH and execute the following command:

  • vi /etc/config/firewall

Add the aforementioned option as shown below:

Once done, execute the following command:

  • /etc/init.d/network restart

Best regards,

by anonymous

To restore saving from the WebUI, you need to login to your router via SSH and edit /etc/config/uhttpd file.

Replace

  • list listen_http 'xxx'
  • list listen_https 'yyy'

With 

  • option listen_http 'xxx'
  • option listen_https 'yyy'

And then restart the service

  • /etc/init.d/uhttpd restart

Best regards,

0 votes
by anonymous
Are there any firmware updates to solve this problem?
by anonymous
Hello,

Solution is set to be included in 7.05 firmware version. Currently its planned release is the second half of may.

Best regards,