FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
277 views 0 comments
by anonymous

Hi,

I've been labbing it up with a RUT955 and a 'USB type Mini - USB type A' cable as described in the guide on the wiki for this setup to connect to my cisco switch's USB mini console port. 


It works and I get the output of my switch's console but I have two issues I wonder if everyone else has with this setup or if there's something I can tweak to fix these things.

First, everytime I press enter running putty while connected to the virtual console my switch recognizes it as if I've pressed enter twice which is a bit annoying. I've tried the described settings in the wiki's guide and have tried tweaking pretty much everything, different Stop bits, 'No leading zeros' on/off, Raw mode on/off, flow control setting off / Xon/Xoff / RTS/CTS and TCP echo on/off with all of these with different combinations. I've also bought another USB cable to see if that might be it, but it worked just the same as before.

The second problem I have is that when using this for console access to a networking device I really prefer my command such as question marks, tab commands to be sent directly to the console without having to press enter. I noticed the only way for this to work was to toggle TCP echo on and it works I can tab and write questions mark and get immediate feedback. But every character I type after enabling this setting is being shown 3 times on my screen. In reality on the device it enters it once but on my screen it shows it three times so when i type 'a' it shows 'aaa' on screen. But if I login to my switch using credentials and type them it accepts it so it seems it's actually only sending one character to the device but showing three on the screen.

Has anyone any ideas what more I can try to fix this?
I'm contemplating if I should I buy a RS232 male to cisco console cable instead and try that instead perhaps if I can't get this to work properly.
I'm running RUT955 on version RUT9_R_00.07.03.4.

1 Answer

0 votes
by anonymous

Ok so I managed to solve it. I needed custom settings set in putty which is the terminal emulator I'm using.
The settings to change for anyone else having this problem is to go to Terminal settings and set Local echo to 'Force off' and Local line editing to 'Force off' aswell. And on the RUT955 config I disabled TCP echo and pretty much used the standard settings.

After this everything works as I want. No more extra line breaks when pressing enter and I can send my 'tab' and 'question mark' directly without the need to press enter aswell. I think solution will work very well for our OOB management.

Settings used:


Putty configuration was set to Auto and I changed it to 'Force off'.