FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
598 views 2 comments
by anonymous

I'm finding that across the board, on all the units I've tested so far, pressing Save & Apply from System → Administration → Access Control results in an error message:

"Server certificate" and "Server key" files are both required

I have tried generating/re-generating the "Simple" certs but that doesn't fix the issue, nor does a reboot.

Any ideas?

by anonymous
I found 2 other threads mentioning this:

https://community.teltonika-networks.com/60939/can-not-change-ipsec-parameters-after-upgrade-from-07-02-to-07

https://community.teltonika-networks.com/60911/cant-save-anything-in-access-control

Apparently it can be fixed by reformmating the /etc/config/uhttpd file, but no details about specifically what needs to be changed were given.

1 Answer

0 votes
by anonymous

Hello,

Below is a comparison between a properly saving uhttpd configuration on the left and showing error in the right.

Replacing 

  •  list listen_http '80'
  •  list listen_https '443'

To 

  •  option listen_http '80'
  •  option listen_https '443'

And then restarting the service with /etc/init.d/uhttpd restart allowed me to save. See if you have a similar configuration.

Best regards,

Best answer
by anonymous
Thank you ZygimantasBliu - yes that is working