FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

12086 questions

14384 answers

22686 comments

36291 members

0 votes
2,049 views 6 comments
by
Where can I find and configure the speed of the WAN interface ?

2 Answers

0 votes
by

Greetings.

Do you want to reduce/limit WAN interface speed? For this, you can use QoS. You will find it in your routers WebUI under Services/QoS:  More information here.

RUT240 defaults for WAN: 

1 x WAN port (can be configured to LAN) 10/100 Mbps, comply IEEE 802.3, IEEE 802.3u standards, supports auto MDI/MDIX

by
No need to limit.

I want to see the status and, if necessary, manually set the speed of the interface, for example, 100mb duplex.
by

Well, the router is working 100 Mbps duplex by default. You don't have to configure anything.

If you want to set the speed limit or turn it down to half-duplex you will have to use QoS. You will find it in your routers WebUI under Services/QoS:  More information here.

If you want to monitor the traffic speed of the WAN interface. Realtime Traffic go to Status / Graphs / Traffic and pick the WAN interface you want to monitor.

by
The Internet provider claims that its interface is running at a speed of 100Mbit. But apparently the interface on my router works at a speed of 10Mbit. I can not see the status and can not manually set the speed.
by

How did you determine that your router is working at the speed of 10 Mbit? If you have performed a speed test. Can you post a screenshot?

And are you sure it is not 10 MB/s ?

If you want to see a real-time speed of the WAN interface use Real-time Traffic go to Status / Graphs / Traffic

0 votes
by
Hello,

you can find physical wan speed over ssh with ethtool.

To install ethtool run:
opkg update
opkg install ethtool

ethtool eth1
by

Thank!

Here is the result.

Please tell me how to set the settings manually and what the error means at the end of the message.

==================================================

Supported ports: [ TP MII ]

        Supported link modes:   10baseT/Half 10baseT/Full

                                100baseT/Half 100baseT/Full

        Supported pause frame use: No

        Supports auto-negotiation: Yes

        Advertised link modes:  10baseT/Half 10baseT/Full

                                100baseT/Half 100baseT/Full

        Advertised pause frame use: No

        Advertised auto-negotiation: Yes

        Link partner advertised link modes:  10baseT/Half 10baseT/Full

        Link partner advertised pause frame use: No

        Link partner advertised auto-negotiation: Yes

        Speed: 10Mb/s

        Duplex: Full

        Port: MII

        PHYAD: 4

        Transceiver: external

        Auto-negotiation: on

        Current message level: 0x000000ff (255)

                               drv probe link timer ifdown ifup rx_err tx_err

by
To change speed and other settings use:

ethtool -s eth1 speed 100 duplex full autoneg off

But your both ends have to be set same, if one have static settings other can't use auto negotiation.

If you are having problems with 10/100 negotiation try to use crossed ethernet cable.