7888 questions

9313 answers

14995 comments

12808 members

0 votes
2,894 views 9 comments
by

RUT240 - we are looking to connect this device to an ethernet internet service and use the 4G as a failover. Most NBN connections in Australia require a VLAN ID on the WAN interface to function, however we are unable to locate where this is?

https://www.tpg.com.au/support/general_settings_fttb

Any assistance would be appreciated. 

by
We can confirm the below solution worked on the RUT240, however we stupidily purchased some RUTX09's thinking the same solution would work, but it doesn't. This really needs to be included in the GUI and supported natively.

1 Answer

+1 vote
by

Hi,

Try this via SSH:

Edit using vi editor: vi  /etc/config/network

Change:

config interface 'wan2'

        option enabled '1'

        option ifname 'eth1'

To  option ifname 'eth1.1' where .1 means VLAN ID.

In order to edit the file, you have to be in insert mode. Press i

In order to get out of vi, you have to be in command mode. Press [Esc] (the escape key).

Then write one of the following command:

:x   - exit and save.

:q! – exit without saving.

Best answer
by
Any future plans to add this feature as far as you know? or maybe is it available on the RUTX09. This would be our primary use for these devices, so it makes them pretty much useless if they don't support VLAN ID's on the WAN interface.

Thanks!
by
OK - I'll give that a go today and let you know. Thanks!
by
Worked! Thank you :-)
by
We have got the same problem here in Germany. All the DSL connection to our providers only accept VLAN tagged ethernet frames. All the wiredWAN traffic has to be VLAN 7 tagged. I would like to suggest, implement this feature to the webinterface. Maybe somwhere in the pppoe or VLAN settings.
by
Agree Stefan. Whilst the above solution does work, it would be more convenient to have the option in the web GUI. Most modern mid-range+ routers have this option.
by
Hello, what exactly do I have to set here so that the Wan traffic only runs over a certain Vlan? I have several networks in the Wan and the router has to connect to a certain Vlan. If I follow the instructions, it will also get the desired address on eth1.vlanID, but will still try to route the traffic via eth1.

My Config for Wan2

config interface 'wan2'
        option metric '8'
        option proto 'dhcp'
        option ifname 'eth1.208'
        option enabled '1'
by

Hello, I have started a new attempt with the current firmware 6.03 and a factory reset. Then I adjusted everything again to exclude errors.

Networks at the Wan port:

Default / Vlan 0 192.168.2.0/24
Vlan 208 172.19.208.0/24

The goal is to use the default gateway from Vlan 208 (172.19.208.0/24) for the Wan side via DHCP and to switch to LTE /GSM in case of network failure.

After adjusting the configuration I get an Ip on eth1.208 from the desired Vlan, but the default gateway is still Vlan 0 (192.168.2.1).

Settings:

cat  /etc/config/network
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0 tap0'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

config interface 'wan'
        option proto 'dhcp'
        option ifname 'eth1'
        option enabled '1'

config interface 'wan2'
        option metric '10'
        option ifname 'eth1.208'
        option proto 'dhcp'

config interface 'wan3'
        option proto 'dhcp'
        option ifname 'wlan0'
        option enabled '0'
        option disabled '1'
        option metric '20'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '0'
        option vid '0'
        option ports '0 2 3 4'

config interface 'ppp'
        option enabled '1'
        option backup '1'
        option metric '10'
        option pincode '1245'
        option ifname 'wwan0'
        option proto 'qmi2'
        option service 'auto'
        option device '/dev/cdc-wdm0'
        option dialnumber '*99#'
        option pppd_options 'noipdefault'
        option pdptype '1'
        option mtu '1500'

config interface 'ppp_usb'

#######

ifconfig

br-lan    Link encap:Ethernet  HWaddr 00:1E:42:15:F1:B8
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
eth0      Link encap:Ethernet  HWaddr 00:1E:42:15:F1:B8
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          Interrupt:5

eth1      Link encap:Ethernet  HWaddr 00:1E:42:15:F1:B9
          inet addr:192.168.2.129  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::21e:42ff:fe15:f1b9/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:4

eth1.208  Link encap:Ethernet  HWaddr 00:1E:42:15:F1:B9
          inet addr:172.19.208.129  Bcast:172.19.208.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1

wlan0     Link encap:Ethernet  HWaddr 00:1E:42:15:F1:BA
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

#######

Route

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         192.168.2.1     0.0.0.0         UG    0      0        0 eth1
172.19.208.0    *               255.255.255.255 UH    10     0        0 eth1.208
172.19.208.0    *               255.255.255.0   U     10     0        0 eth1.208
192.168.1.0     *               255.255.255.0   U     0      0        0 br-lan
192.168.2.0     *               255.255.255.0   U     0      0        0 eth1
192.168.2.1     *               255.255.255.255 UH    0      0        0 eth1

What do I do wrong?
by

Hello,

You are suppose to find specific "wan interface" in configuration file, which has "option ifname 'eth1'" line and add ".208" at the end of it.

However, you have added "eth1.208" to wan2 interface, while, with your configuration, that had to be done with wan interface.

In this case:

 - Reset your router to factory default settings

 - Fully configure router through WebUI, without connecting to SSH.

 - Connect to router via SSH and add ".208" after "eth1" text in appropriate interface (which might not be "wan2". Order depends how to configure router's WAN failover from "Network -> WAN" menu)