FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
581 views 10 comments
by anonymous
I've been developing a system, all working perfectly with RUT955 firmware 7.02.3 but thought before I put it into production I should bump firmware to current version (7.03.4)

First problem I noticed is that the upgrade process wiped the files stored in root's directory. I had recent copies so just inconvenient.

The real problem is that after the upgrade, USB-to-Serial is not connecting to my server, and I cannot even FIND usb-to-serial configuration options in 7.03.4. Since the online documentation for 7.03.3 specifically shows it, I've downgraded back to 7.03.3 but the same problem, and still not showing in the USB TOOLS, just General, Print Server and Expansion Memory.
I can't find a USB TOOLS package to add either.
If I ssh to the device and  # cat /dev/ttyUSB0 I see the data I expect, so the device is detected and running.
Where has USB-Serial gone?
Similarly, the RS485-over-TCP seems to have disappeared? I can no longer connect to the RS485-to-IP I had set up, and can't find any of the RS485 menus that used to be present?
I didn't see any notes in the changelog that these (very useful) facilities were being dropped, so I assume they're just lurking somewhere I can't see?

Edit: ok, so the wiki pages don't seem to match what's actually running. For others who find this post for the same reason, it's now under Services, Serial Utilities, Over IP. Create a new device and it'll be a device name something like rs232_usb_361186e4 you have to select from the Device Name dropdown box.
The RS485 service is now in here too.

I've now managed to get the CLIENT (USB-serial to server) establishing the connection, which is good, however the SERVER (RS485) is doing something weird. After a reboot, the USB serial is connecting to the server, but another server is able to make a CONNECTION to the RS485 service but isn't getting data back. If I go in to Service, Serial Utilities, OverIP, select the RS485 configuration and WITHOUT CHANGING ANYTHING just click "Save and Apply", my application instantly connects...

I have re-checked all my configs, I can't see anything else using the same port, or using the RS485 interface, so why does simply "save and apply" make it start working even though nothing changed?

Update: just updated to 7.03.4 firmware and confirm that again, after a reboot the TCP->RS485 fails to pass data, however if I go in to Service, Serial Utilities, OverIP, and without even selecting anything just hit "Save & Apply" my application connects immediately.
by anonymous
For the archives, I'm happy to report that 7.04 (released this morning) has completely fixed my issues.

Thanks to the team, and especially Andzej.

1 Answer

0 votes
by anonymous

Hi,

So after you simply press 'save & apply' everything works fine until the device is rebooted?

Could you try to connect to your device via CLI/SSH and restart the service via command:

  • /etc/init.d/rs_overip restart

Did it help? If so, you can add this command to the System -> Custom Scripts before the 'exit 0' line:

sleep 10

/etc/init.d/rs_overip restart

exit 0

Kind Regards,

Andzej

by anonymous

Thanks for the suggestion. I just turned the unit off for 15 seconds then back on. Waited for it to reboot. The outgoing USB->Serial-over-TCP connection came up, the incoming RS485-over-TCP went from connection refused (during the later part of the boot) to Failed: (meaning connection established but no data)

Connect fail (1): Connection refused
Connect fail (2): Connection refused
Connect fail (3): Connection refused
Connect fail (4): Connection refused
Connect fail (5): Connection refused
Fail! (1)
Fail! (2)
Fail! (3)
Fail! (4)

 

I then ran the command /etc/init.d/rs_overip restart as requested .  It made no difference to the connecting state and there was no output on the terminal screen from the rs_overip command.

I again went in via the web interface, Services/Serial Utilities/Over IP and hit "Save and Apply" and started getting data
Fail! (13)
1677441860  0.0   0  0.0   0 0.0   0
1677441865  0.0   0  0.0   0 0.0   0

 

by anonymous

Hi,

I've tried to configure RS232 as a client, and RS485 as a server. After the reboot, the connection was established successfully. Although, it took a little longer for the RS485 (server) to connect to the client (the connection was refused at first). But after, the communication was fine.

Would be great if you could share some details regarding your case and configurations.

Also, could you please replicate your issue and generate a troubleshoot file from System -> Administration -> Troubleshoot? You can attach the file by editing your previous question.

Kind Regards,

Andzej

by anonymous

I've got to the bottom of this this afternoon.
The problem is that my device uses 9600, 8 data and EVEN parity.
The RUT955, after a power-up or reboot, is initializing the RS485 interface for 9600, 8 data and NO parity.
I connected my DSO, sent packets and analyzed what was going on.

For right now, until teltonika fix it properly, my cure is in a script that runs after boot, executes this:

# Temporary work-around for the RUT955 not properly initializing the RS485 port
/usr/sbin/sodog -p /dev/rs485 -b 8 -s 9600 -a even -t 1 -m server -c 300 -g -redacted-


 

by anonymous
Hi,

Glad to hear that you have resolved the issue and thanks for letting me know. However, this is odd. I have just tested this with RUT955 with the same firmware version and the same settings (RS485 set as server, 9600, even, etc), but the parity remained the same (even) after the reboot. I was able to communicate without issue.

Would be grea to know if you have you updated the firmware with 'keep settings' turned 'on'? It might be a migration issue if so. Have you tried to restore the device to factory settings? Flashing firmware via bootloader?

Would it be possible to get a troubleshoot file?

Kind Regards,

Andzej
by anonymous
Well, it's not really "resolved" so much as "identified" and an ugly work-around in place :)
Yes, when I updated from 7.02.3 to 7.03.4 I selected "keep settings" as there was a considerable amount of effort already invested in getting the device as I wanted it - particularly with ssh keys and and so on.

Yesterday I sent a troubleshoot file to teltonika (Australia) so you might be able to access the notes etc there?
I will try to make some time to update another RUT955 today without "keep settings" and see if that's different.
(I need to find my notes on making ssh keys etc persistent first.)
by anonymous

Andzej, I have taken another unit, was on 7.02.4, done a firmware upgrade to 7.03.3, UNCHECKED the "Keep settings" option to off.
After the update, all settings were gone. I did a FACTORY RESET by holding the reset button as directed until after all 5 signal strength LEDs lit up, then released. All settings appeared back to factory.

I have manually set up the minimum things I need, and disabled pretty much everything else (like RMS).
I have exactly the same issue! After a reboot, it is sending data out the RS485 port, but with no parity bit. The device is ignoring the command due to parity errors, so no reply.

SSH in and issue the command:

/usr/sbin/sodog -p /dev/rs485 -b 8 -s 9600 -a even -t 1 -m server  -c 300  -g 8880

and everything works perfectly.
Do you want a "Troubleshooting" tarball from after boot (when the problem is evident) and/or after the command is run (when the problem isn't evident)?

by anonymous
Hi,

It would be great to get two troubleshoot files, before and after.

Also, I have sent you a private message.

Kind Regards,

Andzej
by anonymous
Here are two files.    
-pre is after boot, before the "fix" is run.
-post is after the fix.
OK, here ARN'T two files - how can I upload them, I can't see anywhere on the page to upload a file except under "image", and it won't accept a gz file...
by anonymous
Hi,

Please, check the private messages.

You can also send those troubleshoot files to me via private message.

Kind Regards,

Andzej