subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
268 views 1 comments
by anonymous

my teltonika router does not connect to the 4G network.

It is registered in the network (registered (roaming);; 4G (FDD LTE)).

But the data connection stays disconnected (Modem: DATA CONNECTION Disconnected)

I've tried different provider (vodafone, telekom ).

The connection was available until 9.2.23. Then it was lost.

How to solve this problem ?

Thank you in advance.


Data of my Router:

Device name RUT955

Product code RUT955003XXX

Serial number 1122417185

Hardware revision 2017

Batch number 0116

Firmware version RUT9_R_00.07.02

Kernel version 5.4.147

Local device time 2023-02-28 16:11:57

Uptime 01h 06m 34s


Model SLM750

IMEI 868159055775345

FW version SLM750_4.0.6_EQ101

1 Answer

+1 vote
by anonymous


Could you start by updating your device's firmware to 7.3.4 version, which you can download here

If that does not help, I would like you to attach a troubleshoot file to your question. Please, replicate the issue, then access router's WebUI, go to System -> Administration -> Troubleshoot section and download troubleshoot file from there. 

The logs in the file might provide more insight into the issue.

Best regards,

Best answer
by anonymous

thank you. Firmware update solved this issue.

But this approach is not a solution at all. We have may devices in the field, so firmware update should not be the only one solution., because without available connection no firmware update will be possible.
The device lost it's connection without any obvious reason.

i've appended the trouble-shot file to help you to investigate the reason for the problem.