FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
691 views 4 comments
by anonymous

Hello. Is it possible to get resolved ip addresses to dns name with default "DNS" server (RUTXR1) via forwarding to external DNS?

in /etc/config/dhcp file, under section "config dnsmasq" I have following string:

list server '/subdomain.domain.com/192.168.111.222'

I did try to add reverse record, what in GUI looks like: /123.168.192.in-addr.arpa/192.168.111.222 

to get ptr records for subnet 192.168.123.0, but GUI does not allow it (FAILED TO EDIT CONFIGURATION)

So, is it possible at all? What is my mistake?

1 Answer

0 votes
by anonymous

Hello,

Might be another WebUI limitation.

I would like you to try the following:

Login via SSH, execute the following command:

  • vi /etc/config/dhcp

Press letter i to enable editing and add the following line under dnsmasq configuration:

  • list server '/123.168.192.in-addr.arpa/192.168.111.222'

In addition, set boguspriv option to 0:

  • option boguspriv '0'

Once done press Esc, then enter :wq and press Enter.

Lastly, execute the following command:

  • etc/init.d/dnsmasq restart

See if that helps.

Best regards,

Best answer
by anonymous
Thank you. Yes, settings via config file are working. Another GUI issue.
by anonymous
Please note, that this "walkaround" basically blocks this page in GUI from any following changes.

This limitation must be fixed.
by anonymous
This is indeed the result of any changes made via CLI, which are not accepted by the WebUI.

I have registered a ticked for the developers.

Apologies for the inconveniences.
by anonymous

It seems, what there is another problem. I removed conflicted records from config file, restart service.

In the GUI, I have added second interface for DNS server to listen on. This is result in config file:

    option interface 'br_Guest lan'

But in GUI after successfully executing Save and Apply, I still see only "lan".
Here is screenshot: