FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
215 views 6 comments
by anonymous

FW TCR1_R_00.07.03.4

I can't get load balancing to work, almost all traffic is going over one interface, screenshots attached.

1 Answer

0 votes
by anonymous

Hello,

Could you check, what speedtest results do you get for each individual interface?

Also, for some reason the MAC of WAN interface is displayed as zeroes.

I would like you to attach a troubleshoot file to your question. Please, replicate the issue, then access router's WebUI, go to System -> Administration -> Troubleshoot section and download troubleshoot file from there. The logs in the file might provide more insight into the issue.

Best regards,

Best answer
by anonymous

https://community.teltonika-networks.com/?qa=blob&qa_blobid=16509152584219681229

WAN is an ADSL router in bridge mode, ~8mbbs down, 1.5mbps up, 4G is ~30mbps down, 15 up.

by anonymous

Due to higher bandwidth, mobile is preferred interface.

Could you try assigning different ratios to the interfaces: give 1 to mobile, and 4 to wired connectivity. 

Also, enable Software flow offloading in Network -> Firewall -> General settings, to check if that provides any impact on PPPoE performance.

The thing to understand about load balancing implementation in Teltonika devices is that it works on connection basis, meaning that a single connection is made through a single interface, traffic is not combined from both interfaces. Thus, if you are using internet for streaming or large file downloads, it is possible, that most of that will be done through mobile due to it's higher throughput. 

Best regards,

by anonymous

I have tried ratios of up to 99:1 but it does not seem to make any difference.

I have enabled Software flow offloading.

by anonymous
I do not think the bandwidth is the issue, when I change the order of the interfaces in Network>Interfaces>General by dragging and dropping 99.9% of the traffic goes via whichever interface is at the top.
by anonymous

Hello,

I think I found the issue.

The list of rules generated by mwan3 application, responsible for failover/load balancing functionalities is empty, including the default one, meaning that traffic is simply not distributed between interfaces. 

What causes it? 

There appears to be an issue, when more than one source/destination IP address is specified in failover/load balancing rule configuration. In your case that rule is named Banking.

How to solve it?

In Network -> Failover page:

  • Edit Banking rule settings;
  • Remove one of the destination IP addresses;
  • Save Failover settings;
  • Create a separate rule for the other IP address.

Traffic should now be balanced. To check, whether the mwan3 rules are valid, login to the router via CLI/SSH and execute the following command:

  • mwan3 rules

It should provide a list with existing rules under Active ipv4 user rules section.

The issue has been reported to the developers and should be solved with subsequent firmware releases.

Best regards,

by anonymous
That works, thanks.