FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
110 views 0 comments
by anonymous

Hello,
I cannot apply Access Control settings in my TRB141: 
TRB1_R_00.07.04 I get the following error: "Server certificate" and "Server key" files are both required

Is there any solution for that?

Regards Konrad

1 Answer

0 votes
by anonymous

Hello,

This is a known issue, resulting from updating to current firmware from legacy with Keep settings enabled.

You will either need to reset the device to factory defaults or login to router via SSH and make some modifications in order to workaround it. For options, on how to SSH into your device, refer here.

Next you will need to execute the following command, to edit a certain configuration file:

  • vi /etc/config/uhttpd

Press letter i to enable editing and replace the following lines:

  •  list listen_http '80'
  •  list listen_https '443'

To 

  •  option listen_http '80'
  •  option listen_https '443'

Once done press Esc, then enter :wq and press Enter.

Lastly, restart the service with /etc/init.d/uhttpd restart command.

This should allow you to save. 

Best regards,