FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
584 views 2 comments
by anonymous
Hello, I am working with a TRB140 connected a Raspberry Pi which will be deployed at a remote site and I need to be able to SSH into the RPi from our office. I am using NoIP in order to bind it to a specific domain, which works flawlessly when connected to my home router. The only thing I needed to do is forward the SSH port (55798 in my case).

Now, I tried to do the same with the RPi by assigning a static IP to it first and then forwarding the SSH port to this address (following the steps in the online documentation). This however doesn't allow me to SSH into the RPi even though the correct public IP is registered by NoIP. I also tried creating a new zone from wan to lan and accepting all the incoming traffic from wan to lan but this didn't seem to work. Is there any documentation about how to expose a specific port and SSH into it from outside the TRB140 network?

1 Answer

0 votes
by anonymous

Hello,

The configuration should be rather straightforward. I will provide instructions through my example:

  • The first step is to configure a working DDNS setup on your TRB140 device in Services -> Dynamic DNS:

  • Next, navigate to Network -> Firewall -> Port forwards page and add a new rule. The LAN device (RUT240 with IP 192.168.1.202) I want to connect to also has its SSH port set to 55798, thus the rule looks the following:

  • Then I try to connect to the device, using an SSH client:

What happens is my connection request to darvienastest.ddnsfree.com in combination with port 1346 gets me connected to the device 192.168.1.202 on port 55798.

If port forwarding still does not work, I would like to review your configuration. For this, attach a troubleshoot file to your question. To generate the file, access router's WebUI, go to System -> Administration -> Troubleshoot section and download troubleshoot file from there. The logs in the file might provide more insight into the issue.

Best regards,

by anonymous
Thank you for your comment! I followed everything as described but still wasn't able to connect. I updated my original post and attached the troubleshoot file to it.
by anonymous

The IP address your mobile interface is assigned with is not a public IP. 

Unfortunately, neither DDNS, nor direct access from WAN to this IP address will work. 

IP range between 100.64.0.0 and 100.127.255.255 is reserved by ISPs in order to preserve the pool of public IPs, meaning that you are behind at least a layer of CGNAT.

Best regards,