FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
139 views 0 comments
by anonymous
Hello,

We are setting up RUT955 as OpenVPN client. The RUT955 LAN1 connects with a seismic digitizer which has seedlink server inside. We hope to import the digitizer data from seedlink server through OpenVPN. One mobile SIM card is used for the data transport. The RUT955 WebUI shows the mobile data and OpenVPN client are both connected. From our OpenVPN server side, I can ping/telnet the seedlink server. I also can query the seedlink version, the data description(ie, network code, station list), but I cannot import the data.

As test, I do:

1. First, I connect the RUT955 LAN2 with my PC directly. In this case, I think my PC talks to seedlink server through RUT955 but without using OpenVPN. In my PC, I can do everything to the seedlink server, for example, I can query data information, import data and save data file to hard drive.

2. Second try, from my OpenVPN server side, I write obspy code to connect the seedlink server. I can loopily read the data and write to local drive. But after about 100 loops, I get “socket read error: timed out, reconnecting in 30ss”. In this case, my obspy code talks to seedlink server through OpenVPN.   

Any idea to configure RUT955/openVPN to work through?

Thanks.

1 Answer

0 votes
by anonymous

Hi,

Is the VPN connection working fine otherwise? Is the issue only with your obspy code? 

It is hard to say exactly what the issue is. Could you try to lower the rate at which you send requests to see if it helps?

A few more things to try would be to try:

  • Enabling software flow offloading in Network -> Firewall.
  • Checking firewall zone settings and ensure that everything for OpenVPN zone is set to accept.
  • Lowering MTU.
  • Enabling conntrack helpers by executing the following command via CLI/SSH:

echo "net.netfilter.nf_conntrack_helper=1" >> /etc/sysctl.d/11-nf-conntrack.conf

If the issue persists, please, replicate the issue so that it can be seen in the logs and generate a troubleshoot file. Then, attach the troubleshoot file to your question by editing it. Troubleshoot file can be downloaded from System -> Administration -> Troubleshoot.

Kind Regards,

Andzej