FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
332 views 5 comments
by anonymous
Hi!

I use the RUT955 in a Campervan to get Internet Connection over Campground-WLAN in Client Mode.

But since I updated from Firmware 6 to 7 it is not possible any more. The RUT955 always managed to get a IP-Adress from the Campground-WLAN, but gets no Connection to Internet, even if I use the Campgrounds Router as manual DNS (or 8.8.8.8).

I tried it for long time and with many different WLANs - always the same Problem. Actually I tried it on a Hotspot where to log in with a known Password (no username). No captive Screen or anything else. It should work - but it don't. Could this be a firmware-Bug?

Any help is welcome - thanks a lot!

1 Answer

0 votes
by anonymous

Hello,

Please check this video for configuring Teltonika device as a wireless client with current user interface.

If your configuration is correct and there is still no connection, I would like you to attach a troubleshoot file to your question. Please, replicate the issue, then access router's WebUI, go to System -> Administration -> Troubleshoot section and download troubleshoot file from there. The logs in the file might provide more insight into the issue.

Best regards,

Best answer
by anonymous
Thanks for your help. I know this video and did it exactly a shown. With this Workflow the router gets an IP-Adress but no internet-connection. I added the troubleshoot-file to my first post.

Best regards!
by anonymous

Something wrong is happening with your device with current configuration.

The CPU is under heavy load, there are out of memory errors and modem seems to be hung.

Could you triy installing the latest 7.04 firmware with Keep settings option set to off, reconfigure your device and check if the same issue present here?

If it persists, I would like a troubleshoot file from 7.04, to provide it to the development team in order to consult about the possible reasons and solution for the issue.

Best regards,

by anonymous
I did as u said. After the Update on the Page: Status-Overview every second the error-message "Failed to load network-events" and "Failed to load system-events" with a red exclamation-mark is shown. And really - the logs are empty. The CPU-Load seems now lower as before at 10-20%. The Problem with the Client-Mode I will test in the next 1-2 days as soon as I get possibility to catch a free WLAN.

A new troubleshoot-file is uploaded.

Thanks a lot and best regards!
by anonymous

Could you download WinSCP application (link), login to the device, as instructed here (or alternatively login via CLI/SSH), navigate to /log directory and remove/cut log.db file from it? It seems to be taking too much space and is likely the cause for the errors shown in the WebUI.

There is also a mobile modem disconnect, which does not seem to be related to any events, and might be due to the old modem firmware version. If you are having mobile issues, I would also suggest to perform an update and could provide you with the instructions, if needed.

Best regards,

by anonymous
After done as you said (delete log.db and update modem firmware) and reboot the RUT955 everything works fine. No more error messages and also the client-mode of the router works as expected - with internet access.

Thank you very much for your good help!