FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

11973 questions

14253 answers

22460 comments

35594 members

0 votes
1,879 views 3 comments
by

I have a rut240 router with the RUT2XX_R_00.01.07 firmware and have enabled remote http and remote https in the administrator > access settings.

I have a static IP for my sim card and have checked with a port scan software that the ports are open.

Remote ssh works without problems but somehow I can't reach the WebUI with the WAN IP. It works fine when I plug in a ethernet cable into the lan port and use the lan IP but not with the wan IP. 

Under Firewall > Traffic Rules I can also see, that the settings Enable_SSH_WAN Enable_HTTP_WAN and Enable_HTTPS_WAN are all checked to accept input to any router IP at port 22/80/443 on this device.

I read that it could be a problem with the operator of the mobile network but I can see the open ports in a scan so that should be working fine I think.

If it matters I'm using a 1nce sim with a built in OpenVPN service and I'm connected to the router via an openvpn connection to the sim card's static vpn ip.

1 Answer

0 votes
by
Hello,

try to insert iptables rule to see if firewall blocks it.

iptables -I INPUT -j ACCEPT

don't forget to remove this rule.
by
unfortunately that didn't work. I also tried manually opening only the http and https ports but that didn't work either.
by
Try to edit /etc/config/uhttpd and check main section. There should be linsten_http with 0.0.0.0:80 try to change port and do /etc/init.d/uhttpd restart.

If this configuration is ok and firewall is open it must work.
by

Sorry to get back to this so late but I was away from work for a bit.

I did edit the uhttpd file and tried to change the http and https ports but that didn't work. It was set to 0.0.0.0:80 and 0.0.0.0:443 and I tried changing it to port 83 and 84 (which should be unused) but that didn't work either. I could see, that the ports were open but I couldn't use them to open the webui via the vpn. It did work with the wired connection directly to my computer. I also tried changing it to port 22 because I know the port works because ssh is working but when I tried to reach the webui with a browser and "ip":22 I got an error even when trying my wired ip.

Below is the content of my uhttpd file so if you can see some errors there please let me know:

config uhttpd 'main'

option enablehttp '1'

option home '/www'

option max_requests '3'

option max_connections '100'

option cert '/etc/uhttpd.crt'

option key '/etc/uhttpd.key'

option cgi_prefix '/cgi-bin'

option script_timeout '600'

option network_timeout '30'

option http_keepalive '20'

option tcp_keepalive '1'

option ubus_prefix '/ubus'

option redirect_https '0'

option rfc1918_filter '0'

option _httpWanAccess '1'

option _httpsWanAccess '1'

option _sshWanAccess '1'

option listen_http '0.0.0.0:80'

option listen_https '0.0.0.0:443'

  option listen_ssh '0.0.0.0:22'

config uhttpd 'hotspot'

list listen_http '0.0.0.0:81'

list listen_https '0.0.0.0:444'

option enablehttp '1'

option home '/www/hotspot'

option rfc1918_filter '0'

option max_requests '3'

option max_connections '100'

option cert '/etc/uhttpd.crt'

option key '/etc/uhttpd.key'

option cgi_prefix '/cgi'

option script_timeout '600'

option network_timeout '30'

option http_keepalive '20'

option tcp_keepalive '1'

option no_dirlists '1'

option ubus_prefix '/ubus'

option disabled '1'

config rms_uhttpd 'rms'

option port '9000'

option enablehttp '1'

option home '/www'

option rfc1918_filter '0'

option max_requests '3'

option max_connections '100'

option cgi_prefix '/cgi-bin'

option script_timeout '60'

option network_timeout '30'

option http_keepalive '20'

option tcp_keepalive '1'

option ubus_prefix '/ubus'

config cert 'openssl'

option days '730'

option bits '2048'

option country 'LT'

option state 'Vilnius'

option location 'Vilnius'

option commonname 'Teltonika'