FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
556 views 5 comments
by anonymous

I just updated to RUTX_R_00.07.04.1 today, and then tried to enable the FOTA configuration. When clicking "Save and Apply". I get the error "Failed to edit configuration". Looks like a bug in this firmware version. This happens with the FOTA switch in both 'on' and 'off' positions.

2 Answers

0 votes
by anonymous

Hello,

   

Could you clarify which firmware version were you updating from?

I tested it on a RUTX device running RUTX_R_00.07.04.1 and was able to disable/enable it. Once I know which version you updated from, I'll try replicating the issue.

For now, a solution could be to enable the FOTA service using the UCI commands via the CLI:

uci set rut_fota.config.enabled='1'

uci commit rut_fota

/etc/init.d/rut_fota restart

Please check if the issue reappears even after enabling the service this way.

   

Best regards,
DaumantasG

by anonymous
Hey,

It was 00.07.03.01 previously, I believe, but I can't be 100% sure on that. Is there a way I can pull the upgrade history from my router?
by anonymous

Hello,

  

WebUI only shows that the update was performed, but not the version information.

I've tested the update procedure from RUTX_R_00.07.03.1 to RUTX_R_00.07.04.1 with the Keep settings option enabled and was able to enable/disable the FOTA configuration without any error messages.

I believe this might be a one-off case, so I'd recommend resetting the device to factory defaults, which should fix the issue.

Let me know how it goes!

  

Best regards,
DaumantasG

by anonymous
Hi there. I've just had exactly the same issue, after upgrading from 7.02.?? I think? I also upgraded the modem firmware but I dont think that will be related.

I tried the UCI commands, but the FOTA remains OFF and any attempt to turn it on returns the same error?

I then did a Factory Reset, and on reboot the firmware page no longer had the 'FOTA Configuration' tab at all, and when I tried to select 'update from: server' the 'server' was greyed out (could this be because it was already on the latest firmware, so there was no update?).

I then reloaded the previously saved config, and the 'FOTA Configuration' tab returned, and couldnt be turned on.

I have another X11 on firmware 7.04.1. It has the FOTA Configuration switch also OFF, and if I try to turn it on, I get the same error mentioned above.

However, on the 'Update Firmware' page there is an update to 7.04.2 available on the server, and I CAN select 'server' in the 'Update from' area, and then update the firmware, so thats working. It appears to just be an issue with the 'FOTA Configuration' switch, which doesnt appear to stop the updates anyway (at least from 7.04.1).
by anonymous
Hey,

I wasn't able to try the UCI commands, as for some reason I didn't get a notification that you'd responded again on this thread! In the end I factory reset the router, configured it up from scratch again (in case restoring the backup config broke it), and FOTA configuration works for me now. Not sure what would have broken it before, but glad I got it sorted all the same!

If it happens again, I'll try the UCI commands!
by anonymous

It seems to be a problem in the configuration file /etc/config/rut_fota after firmware upgrade. 
The problem seems to persists in upgrade to 00.07.04.3.

To restore saving FOTA-setting from the WebUI, you need to login to your router via SSH or from WebUI and use CLI and edit the file /etc/config/rut_fota.
Logon with username "root" and use the same password as user "admin".

To edit the file you can use the vi editor: An introduction to the vi editor | Enable Sysadmin (redhat.com)

> vi /etc/config/rut_fota
Replace in the first line:
config rutfota 'config'
With (notice the missing underline)
config rut_fota 'config'

Best regards
 

0 votes
by anonymous

It seems to be a problem in the configuration file /etc/config/rut_fota after firmware upgrade. 
The problem seems to persists in upgrade to 00.07.04.3.

To restore saving FOTA-setting from the WebUI, you need to login to your router via SSH or from WebUI and use CLI and edit the file /etc/config/rut_fota.
Logon with username "root" and use the same password as user "admin".

To edit the file you can use the vi editor: An introduction to the vi editor | Enable Sysadmin (redhat.com)

> vi /etc/config/rut_fota
Replace in the first line:
config rutfota 'config'
With (notice the missing underline)
config rut_fota 'config'

Best regards