FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
219 views 2 comments
by anonymous
I want to access the hosts connected to my RUTX11 on ethernet or wifi from my remote Mac client using wireguard. Probably I am not configuring wireguard correctly. Have not been able to find a good guide when I want ot use the regular Mac wireguard client to connect to the RUTX11 to gain access to the hosts connected to the RUTX11.

Have tried searching and testing some recommendations found here. But not found any good guide when using the macos wireguard client to connect to the RUTX11. Not sure what is causing the issue. The RUTX11 is running the latest firmware and I am running the lastest Wireguard client on my Mac.

I am connecting remotely to the RUTX11 using the ddns name so at least I know that the ddns from ddns.net is working.

lan network on RUTX11: 192.168.1.0/24
Wireguard network: 10.0.0.0/24 (10.0.0.1 for the RUTX11 and 10.0.0.2 for the Mac wireguard client)

Do I need to do anything else to get wireguard to work or what have I messed up in the configuration?

Notice: Undefined index: title in /var/www/html/qa-theme/Teltonika/qa-theme.php on line 1490

Notice: Undefined index: title in /var/www/html/qa-theme/Teltonika/qa-theme.php on line 1490

Notice: Undefined index: title in /var/www/html/qa-theme/Teltonika/qa-theme.php on line 1490

Notice: Undefined index: title in /var/www/html/qa-theme/Teltonika/qa-theme.php on line 1604

Notice: Undefined index: title in /var/www/html/qa-theme/Teltonika/qa-theme.php on line 1605
by anonymous
PS: Sorry for the double post, got a cloudflare error message when posting the first time

1 Answer

+1 vote
by anonymous

Hello,

Check the Allowed IPs fields on both sides:

  • on the Mac set it to 10.0.0.1/32 + 192.168.1.0/24
  • on the RUTX set it to 10.0.0.2/24 + the lan IP address of the Mac, and set Route Allowed IPs
  •  check the MTU of the wg interfaces on both sides, be sure to be less than or equal to 1420

Regards,

Best answer

Notice: Undefined index: title in /var/www/html/qa-theme/Teltonika/qa-theme.php on line 1490

Notice: Undefined index: title in /var/www/html/qa-theme/Teltonika/qa-theme.php on line 1490

Notice: Undefined index: title in /var/www/html/qa-theme/Teltonika/qa-theme.php on line 1490

Notice: Undefined index: title in /var/www/html/qa-theme/Teltonika/qa-theme.php on line 1604

Notice: Undefined index: title in /var/www/html/qa-theme/Teltonika/qa-theme.php on line 1605
by anonymous
Thanks a lot @flebourse

That was a quick reply. Set the MTU on the RUTX and added the 192.168.1.0/24 networks to allowed IP's on both the RUTX11 and the mac client. this solved the issues. Didn't find any way to set the MTU on the mac client but it worked when adding the 192.168.1.0/24 to the allowed ip's.