FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
577 views 14 comments
by anonymous

Hello, 

My RUTX10 doesn't seem to be issuing my devices (specifically iOS devices) IP addresses using DHCP connected to an unmanaged switch to a Wireless LAN via 2 x GWN APs which both have static IP addresses.

I have done a Factory Reset and upgraded the Firmware to RUTX_R_00.07.04.1

Please let me know what else may help?

Kind regards

Adam

2 Answers

0 votes
by anonymous

Hello DaumantasG,,

Pretty sure I've fixed the issue, No more LAN on the WAN port.

So far all IP addresses are Issued straight away and in the LAN IP Pool. 

 I'm also connected to my ISP with DHCP and MAC ID is there now.

  1. Factory Reset the RUTX10, Change Mode From Basic -> Advanced (top Right)
  2. Network > VLAN > Add > WAN port = 'Tagged' >VLAN ID Set = 10. (I also SET the VLAN ID 1 & 2 WAN ports to 'Off'). Leave VLAN ID 1 - LAN1, LAN2 & LAN3 as 'Untagged' > Save and Apply.
  3. Network > Interface > General > WAN > PHYSICAL SETTING > Interface  change to 'eth1.10' > save and apply.
  4. That's It, I left all the Interface LAN settings as ‘Default’ i.e Physical Setting > Bridge Interface = Set to ‘On’  and Interface = Set ‘eth0’.

Kind Regards

Adam 

Best answer
0 votes
by anonymous

Hello,

  

From the troubleshoot file, it seems like the device with MAC address xx:xx:xx:xx:e4:6d is receiving DHCP offers from a different DHCP server, and the RUTX10 responds with DHCPNAK and wrong server-ID.

In your DHCP lease list I noticed the device Orbi-Satellite with MAC address xx:xx:xx:xx:xx:99:a8. From a quick Google search, this seems to be a WiFi range extender/router. Could you make sure it's DHCP server feature is disabled? Since it seems like it is conflicting with RUTX10 DHCP server. Also, make sure the access points are set to "dumb AP" mode.

If that does not help, I would like you to navigate to System → Administration → Troubleshoot, and enable the TCP dump option. Select the interface as br-lan, and press Save & Apply. Then, replicate the issue by trying to connect to the AP. After a few failed attempts, in the Troubleshoot menu, press the Download TCP dump file button, and attach the generated file to the original post. Thank you.

  

Best regards,
DaumantasG

by anonymous
Hello,

  

The supplier is most likely referring to the encryption algorithms, as up to v7.4, both TKIP and CCMP ciphers were used. however, now by default only CCMP is used, which is more secure, thus it should not be causing any issues with Apple devices.

As for the firewall rule, let's try changing it to only block destination ports 67 and 68. Remove the source port block and save the rule. Reboot the router and check if the Apple devices are still experiencing issues.

  

Best regards,
DaumantasG
by anonymous

Hello DaumantasG.

thanks for the message,

I've tried your new suggested firewall settings and it didn't work unfortunately. Also in the the picture what are the 'mob1s1a1' and 'mob1s2a1' in my WAN?

i spoke to my ISP provider and they said that there was multiple MAC Addresses Seeking Authentication on their end from our end. They sent me a whole heap of my LAN devices MAC IDs requesting Authentication on their end. They asked if I had bridging 'On'.

After the phone call with ISP I checked Interfaces  > LAN >Physical Settings, 'Bridge Interface' is 'ON'. Should I turn it 'Off'??? 

or what else could be letting LAN devices go around the Firewall?




Kind Regards

Adam

by anonymous

Hello,

  

It seems like I did not notice your network configuration issues. The Interface in the physical settings of the LAN interface should be eth0 and Bridge interfaces should be enabled.

For the WAN settings, open the WAN interface, change the protocol to PPPoE, enter the credentials, and in the advanced settings specify the VLAN tag ID. In the physical settings, bridge interfaces option should be disabled, and as the interface, eth1 should be selected.

The way you have configured it now, you are directly bridging the WAN and LAN interfaces (as your ISP told you).

As for the mob1s1a1 and mob1s2a1 interfaces, these are the mobile interfaces, but they should be hidden in the RUTX10. I will report it to our RnD department, however, it should not affect the functionality of the device.

Let me know how it goes!

  

Best regards,
DaumantasG

by anonymous

Hello DaumantasG,

No those credentials you suggested do not allow to connect to ISP at all, I tried using the VLAN tag in Advanced Setting but it didn't seem to do anything?

In the WAN I used In the physical settings, bridge interface  disabled, and as the interface, eth1.10 VLAN 10 - Tagged on WAN. This config connects to the ISP but the MAC ID is not there, so I think it's the same problem.

In the LAN I used In the physical settings, bridge interface  enabled, and as the interface, eth0.10 VLAN 10 - untagged on LAN but stil No Connectivity.

Kind Regards

Adam

by anonymous

Hello DaumantasG,,

Pretty sure I've fixed the issue, No more LAN on the WAN port.

So far all IP addresses are Issued straight away and in the LAN IP Pool. 

 I'm also connected to my ISP with DHCP and MAC ID is there now.

  1. Factory Reset the RUTX10, Change Mode From Basic -> Advanced (top Right)
  2. Network > VLAN > Add > WAN port = 'Tagged' >VLAN ID Set = 10. (I also SET the VLAN ID 1 & 2 WAN ports to 'Off'). Leave VLAN ID 1 - LAN1, LAN2 & LAN3 as 'Untagged' > Save and Apply.
  3. Network > Interface > General > WAN > PHYSICAL SETTING > Interface  change to 'eth1.10' > save and apply.
  4. That's It, I left all the Interface LAN settings as ‘Default’ i.e Physical Setting > Bridge Interface = Set to ‘On’  and Interface = Set ‘eth0’.

Kind Regards

Adam