FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
230 views 5 comments
by anonymous
I would like to add:

cpe-add-id=123456789

to dnsmasq config, I cannot add via UCI as I get a parse error, due to the hyphens "-"

Is there a way I can add this via the UCI or by adding to a config file somewhere?

Thanks.

1 Answer

0 votes
by anonymous

Hello,

Could you try the following:

  • uci set dhcp.@dnsmasq[-1].add_cpe_id='123456789'

Alternatively, you can try to edit /etc/config/dhcp, with a text editor such as vi, and simply add a following line:

  • option add_cpe_id '123456879' 

Best regards,

by anonymous
The UCI command added it to the dhcp file, but it had underscores.

Do I need to restart dnsmasq or kill -HUP ?
by anonymous

If added with uci, additionally enter:

  • uci commit
  • /etc/init.d/dhcp restart 
by anonymous
I rebooted and that still does not work

I can hack the /etc/init.d/dnsmasq file and it then works, its not a great solution though
by anonymous
I did the uci commit and restart :(
by anonymous

It might be that the option is simply not supported. I was unable to find it OpenWRT list of options.