subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
746 views 6 comments
by anonymous
I’ve a problem with my mobile connection via SIM1 on my RUTX11 on current firmware RUTX_R_00.07.04.1

On connected clients, a speed test shows that no upload is possible at all. The donwload worked fine.
The build in speedtest in the X11 at System -> Speed Test: reveals very good up- and down load rates.

I’ve already three times performed a factory reset with no positive effect on this problem.

Observation: After the first factory reset the upload worked for a while. After around one minute, I performed a reboot and since no upload possible.

After the second factory reset I was not able to reproduce the positive upload  behaviour.

I tested with multiple speed test tools and also on multiple clients, connected to my X11.
Also I verified the APN settings at System -> Setup Wizard -> Mobile. But since the build in speed test shows good up- and download rates, so I guess it’s not an APN problem.

Every creative idea to solve this malfunction would highly appreciated.

4 Answers

0 votes
by anonymous


Does this issue apply for devices connected to the router by both WiFi and wire, or only Wifi/wire?

I would also like to review your device logs. Could you to attach a troubleshoot file to your question? Make sure the issue is present before generating the file, then access router's WebUI, go to System -> Administration -> Troubleshoot section and download troubleshoot file from there. The logs in the file might provide more insight into the issue.

Best regards,

0 votes
by anonymous
Many thanks for your respond!

The issue appears wired as well as on WIFI.

I've attached the troubleshoot file.

If you need further details, please let me know.

Many thanks in advance!
by anonymous
The logs do not indicate any issues with the device or the way it is configured.

Is the upload issue related to mobile connectivity or wireless WAN as well?

Have you tried actual file uploads to some servers, emails?

Would it be possible to arrange a remote via AnyDesk to check up on your device?

Best regards,
0 votes
by anonymous

Sorry for answering so late, but today I was not available.
Great that you had already time to have a look at the log files.

You asked: Is the upload issue related to mobile connectivity or wireless WAN as well?
Answer: Only to mobile connectivity. Only when the traffic goes over mob1s1a1. When I change the network interface order to WLAN connectivity first, there is no problem.

You asked: Have you tried actual file uploads to some servers, emails?
Answer: Yes. I had tested with multiple apps which requires uploads. Including sending an E Mail. Mail with less content can be send, mail with attachment 2 MB, Thunderbird shows error message: closing transmission channel - command timed out.

You asked: Would it be possible to arrange a remote via AnyDesk to check up on your device?
Answer: Yes, that’s mostly everyday possible. Just let me know. I highly appreciate your offer!

Please support in how to test it.

As long as I’m connected to the X11 via mobile connection (SIM1), no upload is possible,  which might disturb the AnyDesk session. Or I connect my client with a LAN cable to the X11 and via WIFI (mobile phone hotspot) to the internet. But having two network connections at one client running, I do not know how to control the routing. I tested it now and traffic goes with the LAN cable to the internet. I can access my X11 as well, but I guess no traffic runs over the X11 from my client computer.

Many thanks in advance and looking forward get more insides into the RUT OS.


by anonymous

A new firmware update was released. Could you try installing it and testing if it improves your current situation?

Firmware file can be downloaded here.

Best regards,

0 votes
by anonymous
Dear all.

I have the same problem. The clients connected via WiFi have no upload speed. Latest update is installed on my RUTX11 but nothing has changed to the upload behavior.

Any ideas?

by anonymous
Speed test on Client in wifi download 6.43MBit /s upload is 0.01Mbit/s

Speedtest with sim card Download 42.2 MBIt and upload 14.0 MBit/s
by anonymous
Dear Sabine,

You have to adapt the MTU size of your mobile interface from 1500 to 1420.

Network -> Interfaces - <mobile interface>: Properties -> Advanced: MTU size = 1420

(e.g. mobile interface one = "mob1s1a1")

I hope that works for your as it did by my problem.

Best regards
by anonymous
Thank you very much for your great support. It works now!

by anonymous
@BTourer: The correct value for the MTU depends on the mobile operator's nework details, it is 1416 for me.

Automatic adjustment worked fine for older firmware versions (07.02.x).

 Thank you for the pointer.