FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
267 views 5 comments
by anonymous
Hi,

I have some RUT955 with FW version: RUT9XX_R_00.06.09.2. I have a GPS device that send NMEA trame via a serial port, be it RS232 and RS485. I configured the routeur, in the case it's a RS485 in server mode OverIP, with parameter like this :

https://ibb.co/9yKsRZD

It transfers data but not the way I want. I can't write the data that we receive, I go above the character limit. But basicaly, the forwarded frame contains <LF><LF> at the end of each line instead of a <CR><LF>. When I plug it directly to a computer in serial, it doesn't have them.

So my question here is, does the routeur add data to the fowarded message, and if so, is there a way to parse the message and return it to it's original state ? Inside the routeur, of course.
by anonymous
I read the documentation and the only thing that is remotely talking about CR/LF is in the Modem mode of the RS232/RS485. Since I am not using it, it shouldn't be relevant right ?

And now, for the other use case, where we use RS232. It is configured like so :

https://ibb.co/Sm9hFrB

Again, when we test it but plugin the RS232 directly to a PC, we can read the data just fine with Putty. But now, we don't even see any response on the port 10110.

We checked the different parameters (Baud rate, data bits...) and everything is correct. In both case, I used telnet like so : telnet 192.168.1.1 10110

I also changed the firewall to allow any traffic, in case it was causing an issue.

Additionaly, multiple equipement will connect to the fowarded port to read the data. I should then change the mode from TCP to UDP to allow multiple connection ?
(I split my message in two because of character limit)

1 Answer

0 votes
by anonymous
Hi,

Is there a reason why you are using legacy firmware? Could you please try updating to the latest firmware version and see if the issue persists? If so, try enabling the 'raw data' option on the latest firmware.

Kind Regards,

Andzej
by anonymous

Hi,

Yes, we would like to use the RUT9XX_R_00.07.X OS, but we are not familiar with it and can't seem to understand how to use it.

We can't seem to make the VLAN work and can't understand. What we do right now is use a port based, so we say than Port 1-3 are on Vlan-1 Port 4 (Wan made to Lan) on Vlan-2. And we don't see the port 4 on the Vlan interface, even when it's port based : https://ibb.co/mJsXPbQ
I did the update and made the change, but we still don't see any data on the specified port : https://ibb.co/xXL27fz

by anonymous

Hello,

Apologies for the late reply.

I am not sure what VLAN configuration you have.

The RUT955 hardware has two physical devices for switch configuration. The first three LAN ports share a single physical device, which is then split into three virtual interfaces. The WAN port is separate and cannot be configured in the port-based section.

VLAN configuration examples are available here.

To clarify, you can configure the WAN port as a LAN port (along with other LAN ports). For example, you can configure the LAN network and WAN port on 192.168.1.0/24 and assign port 2 to a VLAN in port-based VLANs. So it might be that your current configuration is similar. You can find more information about WAN as LAN here.

You can also use the WAN port as a VLAN by assigning it a tag in the interface-based settings. To do this, you first need to configure the WAN port as a LAN port and then add an instance in the Network -> VLAN -> Port Based section of type 802.1Q for eth1 interface. After that, you need to create an interface in the Network -> Interfaces section and assign a physical interface of a previously created VLAN instance.

Regarding serial communication, it's unclear what the issue might be. Have you tried connecting the RUT955 via RS232 to a different device to see if it works?

Kind Regards,

Andzej

by anonymous
Hello,

Thanks you for your reply.

First, by updating the RUT955 to 07.04.2 and selecting RAW mode for RS232, the transmission work. It seems to me that when we don't send the data as raw, the RUT add a new line between each message.

Then, the VLAN configuration I aim to have is this : https://ibb.co/VH9vP3S

I can set up the WAN port as Lan. For that I use the "Alternative 2" method on the link you provided.

I don't understand what you mean by "instance in the Network -> VLAN -> Port Based section of type 802.1Q for eth1 interface". I do not seem to have an option like this : https://ibb.co/dtKnh98

I have opened a ticket regarding the VLAN problem at https://community.teltonika-networks.com/65546/rut955-network-interfaces-on-specific-ethernet-ports?show=65644#c65644

Since the problem regarding the data format on serial connection is solved, should I close the ticket and validate your answer ?
by anonymous
Hello,

"I don't understand what you mean by "instance in the Network -> VLAN -> Port Based section of type 802.1Q for eth1 interface""

Sorry, my bad. I meant to say interface-based, not port based.

Anyways, Based on the network topology, it looks like you don't actually need to use a tagged VLAN on the WAN. Instead, you can simply configure the WAN port as a LAN port.

Then, you can set up port 3 to be a port-based VLAN (LAN_P) on the 192.168.2.0/24 network.

This means that LAN ports 1, 2, and the WAN will all be on the 192.168.1.0/24 network, while port 3 will be on the 192.168.2.0/24 network.

Kind Regards,

Andzej