FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
218 views 1 comments
by anonymous
Hello,

I hope someone can help me with my problem.

I have a RUT241. I have installed package MQTT. I have set all the parameters needed for MQTT Publisher.

I would lile to send MQTT messages when the input pin has changed (on rising edge). If I go to the settings of I/O Juggler, on the Actions tab, under NEW INSTANCE, on the list of the "type" dropdown button, MQTT is missing.

1 Answer

0 votes
by anonymous

Hi,

Did you update the firmware with 'keep settings' turned on by any chance?

Also, make sure you have advanced mode turned on in the upper right corner of the WebUI when you cannot find some of the options in the WebUI. However, the MQTT option should still be visible in basic mode.

First, I would try to clear the browser's cache or use another browser to see if the MQTT option appears. 

Then, try restoring the device to factory default settings in System -> Administration -> Backup.

In case restoring to factory defaults did not solve the issue, I would suggest reinstalling the firmware via the bootloader procedure as described here.

Kind Regards,

Andzej

by anonymous
Hello,

Thanks, the firmware upgrade did the trick! Thanks again!