FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
336 views 2 comments
by anonymous

Hello,

I have a TRB245 modem and am trying to send SMS using the RS232 and AT commands.

With both Full Control and Partial Control settings, the modem always writes the signal back to me, e.g. +QCSQ: "LTE",74,-101,158,-10. The problem is I have no flow control and this causes data collisions.

In partial control, the modem does not even respond to the AT command.

I need the Internet on the Ethernet interface and the ability to send and receive SMS via RS232 at the same time.

What options are there?

Kind regards

 Bernd

3 Answers

0 votes
by anonymous

Hello,

You can disable these "+QCSQ: "LTE",74,-101,158,-10" signal messages by sending "AT+QCSQ=0" AT command to the device.

Once this is done, you should be able to have full control of the device other than the AT commands, since there should no longer be any collisions.

In case you would want (or would not want) a device to echo AT commands which you type, that can be controlled with ATE0 or ATE1 AT commands.

by anonymous

Hello,

That was helpful, but in Modem Control Mode = Partial Control, the modem doesn't even respond to the AT command.

by anonymous

Hello,

Is there another option in modem control mode = full control:

1. AT command for establishing a data connection via Ethernet - ??

2. AT commands for SMS - Ok

0 votes
by anonymous

Hello,

That was helpful, but in Modem Control Mode = Partial Control, the modem doesn't even respond to the AT command.

Is there another option in modem control mode = full control:

1. AT command for establishing a data connection via Ethernet - ??

2. AT commands for SMS - Ok

0 votes
by anonymous

Hello,

I read through other questions/answers about modem control mode - partial control e.g. for TRB142. It was written that CR and LF must be appended to the AT command, I tried it, no answer from the modem?

what else can I try?